summaryrefslogtreecommitdiff
path: root/mail-filter/pyzor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /mail-filter/pyzor
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'mail-filter/pyzor')
-rw-r--r--mail-filter/pyzor/Manifest2
-rw-r--r--mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/mail-filter/pyzor/Manifest b/mail-filter/pyzor/Manifest
index 3dce394454df..1a54e28a890b 100644
--- a/mail-filter/pyzor/Manifest
+++ b/mail-filter/pyzor/Manifest
@@ -1,3 +1,5 @@
DIST pyzor-1.0.0_p20200523.tar.gz 138077 BLAKE2B 13ad30f06ce32a24a42dd5aaa21ad2a6700df1bac3dc54a86532748688b094ee0f56a8e28e34336298388c6e0b95868e95d040866c9afa561d867069496608fe SHA512 afe3b14794aea68b1a7d72840257976c7c9f755a6f6dcaaf6ebacab465c176fe2aa84f3fe176006cdbe26ef0b07ed949f75f6ef729f65c604fadf6ce8472da8f
+DIST pyzor-1.0.0_p20211223.tar.gz 138500 BLAKE2B 242a7b2df3451f659d820771454e685868792bd2275b6d69d4c4adfd6044c781abe2d72fe1500a6074851faf8e88e95d6578c546d4d95fda03e11609d1a0b436 SHA512 218bea40515a21b1e08b2bad5b7ba339ba84fff2da425dc58df72a967730ebe10e319944e1604ff56bb37f6a8ae7bc0cd974b54b18a4878ba103131b8ea47b67
EBUILD pyzor-1.0.0_p20200523.ebuild 1565 BLAKE2B 09a2f7abd6979ffede603c0e20f3a6656481fba2c97a67801dea217440f5e1eff9da8b0efca6ece299be75edd61072760d0dfd53f2d06785f72192c29e104354 SHA512 4c387c7cbafd33ffdc3476844e1eb7314d8b8cc8307c51c8291e270cce580845e61c98d39f4fac5661bd20a546eb44ac656f25275cd0f0e92243dd813770c3e2
+EBUILD pyzor-1.0.0_p20211223.ebuild 1548 BLAKE2B 87ea582e181719a0da6a2f0cba5027be0906668a688a93212fdaad0b26ca8ccfe00dcbfbbd141f40d946a49cc5335ed9b9da67169dd4a17157c9e9892e35e703 SHA512 8ce84a4905cb9cb8157d9f9e7bb323db183ab77456ad2ddb405cfe0ac509877d22052997c333ac0ce032c673f5bb64eace886358527972d1b6aef785e3959a5a
MISC metadata.xml 954 BLAKE2B 62c3a125c862739d03a90657b689242c2e184ffa34b63a59697053cd6385d0d0804c1fa4246146b8fbdb08563d906e4179456b21ee5371889765c53446ebb061 SHA512 1bfbaabcb0b795d2ef3dc4763a46c909c422e23bafd522e072b2d00cc374713c78c005fba26d5df6f8cbbb7a2e411fba36a7741098e17890e4a7dee83b40038f
diff --git a/mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild b/mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild
new file mode 100644
index 000000000000..b7766b0cbbe6
--- /dev/null
+++ b/mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_COMMIT="2dbe627c1ec245db206cdc73bf1f9d785f1512d8"
+DESCRIPTION="A distributed, collaborative spam detection and filtering network"
+HOMEPAGE="https://github.com/SpamExperts/pyzor"
+SRC_URI="https://github.com/SpamExperts/pyzor/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc gdbm gevent mysql pyzord redis test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ pyzord? (
+ gdbm? ( $(python_gen_impl_dep 'gdbm') )
+ gevent? ( dev-python/gevent[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysqlclient[${PYTHON_USEDEP}] )
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
+ )"
+DEPEND="
+ test? (
+ gdbm? ( $(python_gen_impl_dep 'gdbm') )
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
+ )
+"
+
+# TODO: maybe upstream would support skipping tests for which the
+# dependencies are missing?
+REQUIRED_USE="
+ pyzord? ( || ( gdbm redis ) )
+ test? ( gdbm redis )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ pytest -vv tests/unit || die "Tests fail with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use pyzord; then
+ dodir /usr/sbin
+ mv "${ED}"/usr/bin/pyzord* "${ED}/usr/sbin" \
+ || die "failed to relocate pyzord"
+ else
+ rm "${ED}"/usr/bin/pyzord* || die "failed to remove pyzord"
+ fi
+}