summaryrefslogtreecommitdiff
path: root/mail-filter/pyzor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /mail-filter/pyzor
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'mail-filter/pyzor')
-rw-r--r--mail-filter/pyzor/Manifest5
-rw-r--r--mail-filter/pyzor/files/read-stdin-as-binary-in-get_input_msg.patch85
-rw-r--r--mail-filter/pyzor/files/unfix-configparser-compat-for-2to3.patch41
-rw-r--r--mail-filter/pyzor/metadata.xml28
-rw-r--r--mail-filter/pyzor/pyzor-1.0.0-r1.ebuild71
5 files changed, 230 insertions, 0 deletions
diff --git a/mail-filter/pyzor/Manifest b/mail-filter/pyzor/Manifest
new file mode 100644
index 000000000000..bef5b63ee8dd
--- /dev/null
+++ b/mail-filter/pyzor/Manifest
@@ -0,0 +1,5 @@
+AUX read-stdin-as-binary-in-get_input_msg.patch 2751 BLAKE2B c348d28eeb703ff9b257c915ba6c6ac62e95a1f389173ff2fcd034dbcfdf8b9d9fd075365b9033fe13a3f5ec6a24dad5110c468f54dc5417241cf5cb95e5933f SHA512 424d7b640e4f297bde5e98c92b7fec48c79998b07a710f685f786c673ef10981efc71647973fdd05ac84879387ab5eb97d5c734bf5b03827dd998cf292948d5b
+AUX unfix-configparser-compat-for-2to3.patch 1210 BLAKE2B 1ad8b2528cbf723d46d18c25163f68738281c48638b86c8809b5dab8f6f3c0058f17b1e2232d7c704b4aa777aaaf43c63170478da95272e75492bbbaec696789 SHA512 d9f5308d1f9280db5a0556fcaf3927e261b6cd1d01ff42c05a912335c6f9343f78096eed645aab5c741c221adf5ece00137aa3ae6f950cafbeb77db1908949b9
+DIST pyzor-1.0.0.tar.gz 126276 BLAKE2B c60f26c53bf118c88dacbc49ddd414473748af1868b383a9c937ecf3cfe426ecdd60f64388fe7e555bd4641ef445769600e40879279dd544ef9ea32bd0dab6b9 SHA512 b3fb8b2c5261e187a2ab3a5a3b12d221df7de08766c6bb2ad9990c0f23517534871ecc9d5ad529e79b0d0aef8b2b800728320c57435a8c0d8c3f80a4ba0f7e4a
+EBUILD pyzor-1.0.0-r1.ebuild 2015 BLAKE2B bcbd30619b39d43b93ce6445cf986bff42dd1e7d4d1afd1f0c24aea1dc7a456de2840280c5455cacca55c90fdec80ca61fc36091676a800cf3a61b20fe975d88 SHA512 e2a0e1cb9be39ce9f3c1e44ee6de79ecb62d1ac66fd32e75c0b340ffaa5de842f945203fb58fb5723ebb8c12392d07567971d37fcbd744afa92d9e89dc2e8466
+MISC metadata.xml 887 BLAKE2B 5a399af14ad9aa5eefe9f37da9b43addf24e6c5416827721f110a5cceb44eb9f03c78ac0b149f31468e5206a10c93c98d3940783c39ffa8f04b840a94c3fa850 SHA512 c3967f9f0e2c64f510f04e7ce01f89a2c03a7e1f260ca25a3d29b6c7821dbcded3ffa4b16f640693b08f3763793c733689c30ef8710305a4bf0b706605eda138
diff --git a/mail-filter/pyzor/files/read-stdin-as-binary-in-get_input_msg.patch b/mail-filter/pyzor/files/read-stdin-as-binary-in-get_input_msg.patch
new file mode 100644
index 000000000000..03031a976690
--- /dev/null
+++ b/mail-filter/pyzor/files/read-stdin-as-binary-in-get_input_msg.patch
@@ -0,0 +1,85 @@
+From 66225b32d2774cf37fa7f702f7eb26cd94094482 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sun, 4 Mar 2018 17:27:01 -0500
+Subject: [PATCH 1/1] scripts/pyzor: replace the client with the git (+ issue
+ 64 fix) version.
+
+---
+ scripts/pyzor | 33 +++++++++++++++++++++++++++------
+ 1 file changed, 27 insertions(+), 6 deletions(-)
+
+diff --git a/scripts/pyzor b/scripts/pyzor
+index 19b1d21..86c6f7d 100755
+--- a/scripts/pyzor
++++ b/scripts/pyzor
+@@ -17,9 +17,9 @@ import tempfile
+ import threading
+
+ try:
+- import ConfigParser
+-except ImportError:
+ import configparser as ConfigParser
++except ImportError:
++ import ConfigParser
+
+ import pyzor.digest
+ import pyzor.client
+@@ -110,7 +110,7 @@ def load_configuration():
+ config = ConfigParser.ConfigParser()
+ # Set the defaults.
+ config.add_section("client")
+- for key, value in defaults.iteritems():
++ for key, value in defaults.items():
+ config.set("client", key, value)
+ # Override with the configuration.
+ config.read(os.path.join(options.homedir, "config"))
+@@ -171,14 +171,35 @@ def _get_input_digests(dummy):
+
+
+ def _get_input_msg(digester):
+- msg = email.message_from_file(sys.stdin)
++ msg = email.message_from_bytes(get_binary_stdin().read())
+ digested = digester(msg).value
+ yield digested
+
+
++def _is_binary_reader(stream, default=False):
++ try:
++ return isinstance(stream.read(0), bytes)
++ except Exception:
++ return default
++
++
++def get_binary_stdin():
++ # sys.stdin might or might not be binary in some extra cases. By
++ # default it's obviously non binary which is the core of the
++ # problem but the docs recommend changing it to binary for such
++ # cases so we need to deal with it.
++ is_binary = _is_binary_reader(sys.stdin, False)
++ if is_binary:
++ return sys.stdin
++ buf = getattr(sys.stdin, 'buffer', None)
++ if buf is not None and _is_binary_reader(buf, True):
++ return buf
++ raise RuntimeError('Did not manage to get binary stdin')
++
++
+ def _get_input_mbox(digester):
+ tfile = tempfile.NamedTemporaryFile()
+- tfile.write(sys.stdin.read().encode("utf8"))
++ tfile.write(get_binary_stdin().read())
+ tfile.seek(0)
+ mbox = mailbox.mbox(tfile.name)
+ for msg in mbox:
+@@ -372,7 +393,7 @@ def genkey(client, servers, config, hash_func=hashlib.sha1):
+ return False
+ # pylint: disable-msg=W0612
+ salt = "".join([chr(random.randint(0, 255))
+- for unused in xrange(hash_func(b"").digest_size)])
++ for unused in range(hash_func(b"").digest_size)])
+ if sys.version_info >= (3, 0):
+ salt = salt.encode("utf8")
+ salt_digest = hash_func(salt)
+--
+2.13.6
+
diff --git a/mail-filter/pyzor/files/unfix-configparser-compat-for-2to3.patch b/mail-filter/pyzor/files/unfix-configparser-compat-for-2to3.patch
new file mode 100644
index 000000000000..93d0f07a2579
--- /dev/null
+++ b/mail-filter/pyzor/files/unfix-configparser-compat-for-2to3.patch
@@ -0,0 +1,41 @@
+From e4f06e21f697b863fa45a50e535ff0c6e3621a60 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sun, 25 Mar 2018 10:14:21 -0400
+Subject: [PATCH 1/1] scripts/pyzor: undo ConfigParser python-3.x
+ compatibility.
+
+The build system for pyzor-1.0.0 still runs the 2to3 utility on the
+scripts to be installed. As an unintended side-effect, the python-3.x
+"try... import... except" compatibility block for the ConfigParser <->
+configparser module gets modified (the module name gets mistakenly
+lowercased).
+
+This commit puts back the python-2.x "import ConfigParser" line
+unconditionally, and we'll have to rely on 2to3 to fix it when run
+under python-3.x. In newer versions of pyzor, the automatic 2to3 will
+not happen.
+
+Bug: https://bugs.gentoo.org/643692
+---
+ scripts/pyzor | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/scripts/pyzor b/scripts/pyzor
+index 86c6f7d..2750d92 100755
+--- a/scripts/pyzor
++++ b/scripts/pyzor
+@@ -16,10 +16,7 @@ import optparse
+ import tempfile
+ import threading
+
+-try:
+- import configparser as ConfigParser
+-except ImportError:
+- import ConfigParser
++import ConfigParser
+
+ import pyzor.digest
+ import pyzor.client
+--
+2.16.1
+
diff --git a/mail-filter/pyzor/metadata.xml b/mail-filter/pyzor/metadata.xml
new file mode 100644
index 000000000000..77b1c62d6729
--- /dev/null
+++ b/mail-filter/pyzor/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <use>
+ <flag name="pyzord">Enable the pyzord server daemon</flag>
+ <flag name="gdbm">
+ Enables the Gdbm back-end database engine for pyzord
+ </flag>
+ <flag name="redis">
+ Enables the redis back-end database engine for pyzord through
+ <pkg>dev-python/redis-py</pkg>
+ </flag>
+ <flag name="gevent">
+ Use <pkg>dev-python/gevent</pkg> to enable asynchronous operation
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">SpamExperts/pyzor</remote-id>
+ <remote-id type="sourceforge">pyzor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/mail-filter/pyzor/pyzor-1.0.0-r1.ebuild b/mail-filter/pyzor/pyzor-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..1cf021784362
--- /dev/null
+++ b/mail-filter/pyzor/pyzor-1.0.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+inherit distutils-r1
+
+MY_PV="1-0-0"
+DESCRIPTION="A distributed, collaborative spam detection and filtering network"
+HOMEPAGE="https://github.com/SpamExperts/pyzor"
+SRC_URI="https://github.com/SpamExperts/pyzor/archive/release-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc gdbm gevent pyzord redis test"
+# The test suite is py2-only
+RESTRICT="test"
+
+# The mysql-python library is always required for the MySQL engine. We
+# depend on it conditionally here because otherwise repoman will balk at
+# the potential conflict between PYTHON_TARGETS and USE=mysql. But as a
+# result, if you try to use the MySQL engine with python-3.x, it just
+# won't work because you'll be missing the library.
+RDEPEND="
+ pyzord? (
+ gdbm? ( $(python_gen_impl_dep 'gdbm') )
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
+ gevent? ( dev-python/gevent[${PYTHON_USEDEP}] )
+ )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+# TODO: maybe upstream would support skipping tests for which the
+# dependencies are missing?
+REQUIRED_USE="pyzord? ( || ( gdbm redis ) )
+ test? ( gdbm redis )"
+S="${WORKDIR}/${PN}-release-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/read-stdin-as-binary-in-get_input_msg.patch"
+ "${FILESDIR}/unfix-configparser-compat-for-2to3.patch"
+)
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" ./tests/unit/__init__.py
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/.build/html/. )
+ distutils-r1_python_install_all
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use pyzord; then
+ dodir /usr/sbin
+ mv "${D}"usr/bin/pyzord* "${ED}usr/sbin" \
+ || die "failed to relocate pyzord"
+ else
+ rm "${D}"usr/bin/pyzord* || die "failed to remove pyzord"
+ fi
+}