summaryrefslogtreecommitdiff
path: root/mail-filter/opendmarc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-04 08:04:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-04 08:04:48 +0100
commitb46abba85084f65c8b5d619bfc4e2c5373ad4067 (patch)
tree605bf2723f935f10b93678a969b730394d570e2c /mail-filter/opendmarc
parent00d9a8fc3e9e5bafeff6747e978c1685b384e587 (diff)
gentoo auto-resync : 04:08:2022 - 08:04:47
Diffstat (limited to 'mail-filter/opendmarc')
-rw-r--r--mail-filter/opendmarc/Manifest1
-rw-r--r--mail-filter/opendmarc/opendmarc-1.4.1.1-r5.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/mail-filter/opendmarc/Manifest b/mail-filter/opendmarc/Manifest
index 02b386a6af06..fa788debf893 100644
--- a/mail-filter/opendmarc/Manifest
+++ b/mail-filter/opendmarc/Manifest
@@ -5,4 +5,5 @@ AUX opendmarc.initd 1521 BLAKE2B a397bbcbd6eb773ec8b80ac1243578391b1afb65830c726
AUX opendmarc.service 800 BLAKE2B 866b1aaa0c8570494ac56aaa9962821204a7a24437cdb8bec0343c716cfc1d3748a368a32ec314dfce7e4264188cfb1dff51212d60340d4be8e33394a85486f6 SHA512 b140dc3ac99ee7c3dcee80743d6c4295dec4ce5090ab9f560ffe35f9d5e63c7f5af871edcc759be462b8110706028c047cd05ae910a74ecba0436620d6b291bb
DIST opendmarc-1.4.1.1.tar.gz 426618 BLAKE2B a74b2623bc35abb5c34f8d1eff737c71af8f5cadfd6a5d0a85adb6536efd2958118f9da25dd9b736dc24563221968c4ee1ff99b101fa30909764563bda2a8d88 SHA512 ee034386c70c75b87ca2fce0849a1a3538e10e0aebfb0fc9dcba6817d2cf71f52aa5586ccaacdee620190c5fbb81498419fb8e8db9fac15d7c71a61a7da396a6
EBUILD opendmarc-1.4.1.1-r4.ebuild 1739 BLAKE2B 6c3f8849951fa3a0e7215053a46dc8dd52d3dbb6ba380fd46812a7332e66cca3cad0bc734ea40e1b59c8f4b1cca973c61999c5e283a38622bb67a042c73584e7 SHA512 fe8ad02b7e8a53f34c012665fe75c465645c7c0390aec31da04cb6bb4c85ab6525f6179da63b5d5f9507bddc5b27589a0d745c674b1be0bddb190c627c7ba30f
+EBUILD opendmarc-1.4.1.1-r5.ebuild 1716 BLAKE2B 97d7af348a6c42a0a4db000e36fb9f5c48aa6bbf1549ff1a1f6aac50387a4444536161335dc1b5f96c5ba935e0f911ea88c0406428cc3b619826674f2e115de9 SHA512 2cce3c29b10bbc3464cf1437412522fe7d982f526d2db54d82c16ec5518078f0a914716e2cd792a28259705498aeae83f53d7009c9779942712eb4e87b283e2c
MISC metadata.xml 513 BLAKE2B 6af2b5fb83bcc5e942e86f2d57455a54209186f8786fb6e76ce558c4bb0167d85ce419f7270e9b6e83914bdc8d0e963dc285227700bc5940096bbdbf78da93dd SHA512 eef3e5d89bf553098937118f2454cf0a7d715b31e2e49f5648260fd8c7abd03676f7a4047843e621406b54bb3c16bd4aa1409dc56d6d5ab0267a628a0cb15a99
diff --git a/mail-filter/opendmarc/opendmarc-1.4.1.1-r5.ebuild b/mail-filter/opendmarc/opendmarc-1.4.1.1-r5.ebuild
new file mode 100644
index 000000000000..c78d15504262
--- /dev/null
+++ b/mail-filter/opendmarc/opendmarc-1.4.1.1-r5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Open source DMARC implementation"
+HOMEPAGE="http://www.trusteddomain.org/opendmarc/"
+SRC_URI="https://github.com/trusteddomainproject/OpenDMARC/archive/rel-${PN}-${PV//./-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/OpenDMARC-rel-${PN}-${PV//./-}"
+
+LICENSE="BSD"
+SLOT="0/3" # 1.4 has API breakage with 1.3, yet uses same soname
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
+IUSE="spf +reports"
+
+DEPEND="mail-filter/libmilter:=
+ reports? ( dev-perl/DBI )"
+RDEPEND="${DEPEND}
+ acct-user/opendmarc
+ reports? (
+ dev-perl/DBD-mysql
+ dev-perl/HTTP-Message
+ dev-perl/Switch
+ )
+ spf? ( mail-filter/libspf2 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.1.1-CVE-2021-34555.patch
+ "${FILESDIR}"/${PN}-1.4.1.1-underlinking.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+ if use !reports ; then
+ sed -i -e '/^SUBDIRS =/s/reports//' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with spf) \
+ $(use_with spf spf2-include "${EPREFIX}"/usr/include/spf2) \
+ $(use_with spf spf2-lib "${EPREFIX}"/usr/$(get_libdir))
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/opendmarc.initd opendmarc
+ newconfd "${FILESDIR}"/opendmarc.confd opendmarc
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ dodir /etc/opendmarc
+
+ # create config file
+ sed \
+ -e 's:^# UserID .*$:UserID opendmarc:' \
+ -e "s:^# PidFile .*:PidFile ${EPREFIX}/var/run/opendmarc/opendmarc.pid:" \
+ -e '/^# Socket /s:^# ::' \
+ "${S}"/opendmarc/opendmarc.conf.sample \
+ > "${ED}"/etc/opendmarc/opendmarc.conf \
+ || die
+}