summaryrefslogtreecommitdiff
path: root/mail-filter/mimedefang/mimedefang-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-25 09:53:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-25 09:53:29 +0100
commitcf9065b9fe1f8c33a6e488fce1ee75d893cd351f (patch)
treeba764e9926b855c14e54b63112216041a4ab7e51 /mail-filter/mimedefang/mimedefang-3.1.ebuild
parent1bb02f2ca2710df2358072c9a036ae83d2ece88c (diff)
gentoo auto-resync : 25:10:2022 - 09:53:29
Diffstat (limited to 'mail-filter/mimedefang/mimedefang-3.1.ebuild')
-rw-r--r--mail-filter/mimedefang/mimedefang-3.1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/mail-filter/mimedefang/mimedefang-3.1.ebuild b/mail-filter/mimedefang/mimedefang-3.1.ebuild
new file mode 100644
index 000000000000..80c4242a862d
--- /dev/null
+++ b/mail-filter/mimedefang/mimedefang-3.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Antispam, antivirus and other customizable filters for MTAs with Milter support"
+HOMEPAGE="https://www.mimedefang.org/"
+SRC_URI="https://mimedefang.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clamav +poll test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || ( mail-mta/sendmail mail-mta/postfix )
+ acct-group/defang
+ acct-user/defang
+ dev-perl/Digest-SHA1
+ dev-perl/IO-stringy
+ dev-perl/MailTools
+ dev-perl/MIME-tools
+ dev-perl/Unix-Syslog
+ mail-filter/libmilter:=
+ virtual/perl-MIME-Base64
+ clamav? ( app-antivirus/clamav )
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-perl/Test-Class
+ dev-perl/Test-Most
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.72-ldflags.patch"
+ "${FILESDIR}/${PN}-vendor.patch"
+ "${FILESDIR}/${PN}-tests2.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ --with-user=defang
+ $(use_enable poll)
+ $(use_enable clamav)
+ $(use_enable clamav clamd)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_STRIP_FLAG="" install
+
+ fowners defang:defang /etc/mail/mimedefang-filter
+ fperms 644 /etc/mail/mimedefang-filter
+ insinto /etc/mail/
+ newins "${S}"/SpamAssassin/spamassassin.cf sa-mimedefang.cf
+
+ keepdir /var/spool/{MD-Quarantine,MIMEDefang}
+ fowners defang:defang /var/spool/{MD-Quarantine,MIMEDefang}
+ fperms 700 /var/spool/{MD-Quarantine,MIMEDefang}
+
+ keepdir /var/log/mimedefang
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ dodoc -r examples contrib
+}
+
+pkg_postinst() {
+ elog "You can install Mail::SpamAssassin (mail-filter/spamassassin) and"
+ elog "HTML::Parser (dev-perl/HTML-Parser) even after installing if you require"
+ elog "them as they are loaded at run-time."
+}