summaryrefslogtreecommitdiff
path: root/mail-filter/libmilter/libmilter-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /mail-filter/libmilter/libmilter-1.0.2.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'mail-filter/libmilter/libmilter-1.0.2.ebuild')
-rw-r--r--mail-filter/libmilter/libmilter-1.0.2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/mail-filter/libmilter/libmilter-1.0.2.ebuild b/mail-filter/libmilter/libmilter-1.0.2.ebuild
index a804150cb01b..92db49b2c8a4 100644
--- a/mail-filter/libmilter/libmilter-1.0.2.ebuild
+++ b/mail-filter/libmilter/libmilter-1.0.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=7
-inherit eutils multilib toolchain-funcs
+inherit multilib toolchain-funcs
# This library is part of sendmail, but it does not share the version number with it.
# In order to find the right libmilter version number, check SMFI_VERSION definition
@@ -17,7 +17,7 @@ SRC_URI="ftp://ftp.sendmail.org/pub/sendmail/sendmail.${SENDMAIL_VER}.tar.gz"
LICENSE="Sendmail"
SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="ipv6 poll"
DEPEND="!mail-mta/sendmail
@@ -27,8 +27,9 @@ RDEPEND="!mail-mta/sendmail"
S="${WORKDIR}/sendmail-${SENDMAIL_VER}"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-build-system.patch
- epatch "${FILESDIR}"/${PN}-sharedlib.patch
+ eapply "${FILESDIR}"/${PN}-build-system.patch
+ eapply "${FILESDIR}"/${PN}-sharedlib.patch
+ default
local CC="$(tc-getCC)"
local ENVDEF="-DNETUNIX -DNETINET"
@@ -45,7 +46,7 @@ src_prepare() {
src_compile() {
pushd libmilter
- emake -j1 MILTER_SOVER=${PV} || die "libmilter compilation failed"
+ emake -j1 MILTER_SOVER=${PV}
popd
}
@@ -58,9 +59,8 @@ src_install () {
MANOWN=root MANGRP=0 INCOWN=root INCGRP=0 \
MSPQOWN=root CFOWN=root CFGRP=0 \
MILTER_SOVER=${PV} \
- install -C obj.*/libmilter \
- || die "install failed"
+ install -C obj.*/libmilter
dodoc libmilter/README
- dohtml libmilter/docs/*
+ dodoc libmilter/docs/*
}