summaryrefslogtreecommitdiff
path: root/mail-filter/gld
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /mail-filter/gld
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'mail-filter/gld')
-rw-r--r--mail-filter/gld/Manifest2
-rw-r--r--mail-filter/gld/gld-1.7-r4.ebuild (renamed from mail-filter/gld/gld-1.7-r3.ebuild)29
2 files changed, 18 insertions, 13 deletions
diff --git a/mail-filter/gld/Manifest b/mail-filter/gld/Manifest
index 9feac3510616..8d2efa2a3bf2 100644
--- a/mail-filter/gld/Manifest
+++ b/mail-filter/gld/Manifest
@@ -2,5 +2,5 @@ AUX gld.rc 443 BLAKE2B da060c3e9c29b4a12a1e8d74c29b82f9d29943864cdbdd4e4fd6ee502
AUX tables.sql 1141 BLAKE2B 0154c7dfe7a1761c15c2548990d5fb3889218287e7f5a4ddb943d871245d2aafe4d4cac014855dcfb3dd9fbaf9e950b0d2be9d6135eb4527e99b4521d5197dcd SHA512 4501ffb273f7064f1bbb56dd6d3f433532924da52c9007d089c57a27aff9cfda2f4b0a59844d0c8e5ff8ce9218f66316914a5af2c801eacba489d003806bb56a
DIST gld-1.7.tgz 40241 BLAKE2B 3ec3f28d933da4cf7cbb5d66188f162be6d4d6882c5c1d6a143ca6ce1222e92abb7f0e67dba6cb49e9af5b9b2eec9ec962c82edea97aa305efe23acda2825c8b SHA512 68bbfd03295c2895608f8404ca1a0942c53003af66d70fda0e2515717ab8e6836f2b609942633b6d70a15b49338a887b5b1082ed1d9bc7c2c0aa3a7735abb13e
EBUILD gld-1.7-r2.ebuild 1875 BLAKE2B 1f2f2dccb676953a92aa4933fdd8a4ee580500c5118327d1c2ea950cbe6a92879a133d7a742d96409253e73df5a0a5409270ad9c9fba1e8a54269d3c982e618f SHA512 16e11bd850678ef303a81fab386870bc54d9a6341f66ac55e8a84b3d0d86cf9f0fccb3aec9cd39c0eff906eac976e554c055e91c197af8f91eadb35414b931ab
-EBUILD gld-1.7-r3.ebuild 1929 BLAKE2B c2a3e3266e8c292a02287aa57899cb59a4e8945c54db46902b55f1c1d6959cdd7ea740b7977f6bcb00a81f910a206c26f5ecc10fa02de71c991fd9b17241d89a SHA512 7bd8f2401b6fb94bcfb98cb0b8bad2ed89e76df04f0fee17e738c574a823021f533811961889cce7778b05cf2b333e34d36fea71b241164e6d045272cce75f9e
+EBUILD gld-1.7-r4.ebuild 2052 BLAKE2B c9478b99900909a4c2fd744d6d352283c95292337675fedc2b9faaede5486a0d8ae0490bc50f1584e67e6103c4ee55ff09d20eb411a4ee17c1cc40937c42357e SHA512 b93674a81aa7463e7aad21f10c616e3797e47433625f97868849323ab2e1f89096fc993006e70ef7201de2c53c24ce44b84efb6a0eea7dd23864ada3f4b0e099
MISC metadata.xml 240 BLAKE2B eeb6099e7ebc29b81588528b970830d2461fa16783bda673672d405615e46d240dcd806b3d18b6207ef8e5365f8860aa20c304394c3f5b267c5ea4dc739cb94b SHA512 97824dbce22630efb21e647b55212b7a8a19d8e38b5bf05cb0b8078530bbbaaf4dc91284e2a11beab7dfcfb779df82b87b49d11a746c7a4f6dc71f2fda8942db
diff --git a/mail-filter/gld/gld-1.7-r3.ebuild b/mail-filter/gld/gld-1.7-r4.ebuild
index 90926c4222af..c367f5ee96a7 100644
--- a/mail-filter/gld/gld-1.7-r3.ebuild
+++ b/mail-filter/gld/gld-1.7-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
inherit toolchain-funcs
@@ -17,7 +17,7 @@ IUSE="libressl postgres"
DEPEND="sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl )
- !postgres? ( virtual/mysql )
+ !postgres? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:*[server] )"
RDEPEND="${DEPEND}"
@@ -37,17 +37,19 @@ src_prepare() {
sed -i tables.{my,pg}sql \
-e '/ip char/s/16/39/' \
|| die "sed sql tables failed"
+
+ sed -i configure \
+ -e "/SQL_LIBS/{s~/lib~/$(get_libdir)~g}" || die
+
+ default
}
src_configure() {
tc-export CC
+
# It's kind of weird. $(use_with postgres pgsql) won't work if you don't
# use it...
- if use postgres ; then
- myconf="${myconf} --with-pgsql"
- fi
-
- econf ${myconf}
+ econf $(usex postgres '--with-pgsql' '')
}
src_install() {
@@ -69,9 +71,12 @@ pkg_preinst() {
elog "details on how to setup gld."
elog
elog "The sql files have been installed to /usr/share/${PN}/sql."
- if [[ $REPLACING_VERSIONS == "1.7-r1" ]]; then
- elog "You might want to use the ALTER_TABLE command to change the"
- elog "ip field width to 39 chars to accomodate ipv6 addresses."
- elog "Please see your sql server documentation."
- fi
+ local old_ver
+ for old_ver in ${REPLACING_VERSIONS} ; do
+ if ver_test ${old_ver} -eq "1.7-r1" ; then
+ elog "You might want to use the ALTER_TABLE command to change the"
+ elog "ip field width to 39 chars to accomodate ipv6 addresses."
+ elog "Please see your sql server documentation."
+ fi
+ done
}