summaryrefslogtreecommitdiff
path: root/mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild')
-rw-r--r--mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild b/mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild
new file mode 100644
index 000000000000..9c12f98603f6
--- /dev/null
+++ b/mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils flag-o-matic ltprune
+
+DESCRIPTION="This is an IPv4 and IPv6 capable GeoIP dlfunc library for Exim"
+HOMEPAGE="https://dist.epipe.com/exim/"
+SRC_URI="https://dist.epipe.com/exim/exim-geoipv6-dlfunc-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/geoip
+ mail-mta/exim[dlfunc]"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/exim-geoipv6-dlfunc-${PV}"
+
+src_configure() {
+ append-cppflags "-I/usr/include/exim -DDLFUNC_IMPL"
+ econf
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}