summaryrefslogtreecommitdiff
path: root/mail-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
commit20325cfc3bd40d48d3c7034afaac4f5193d9c704 (patch)
treeb8e6ff7fc02271595e20f956b32cef56c41dafca /mail-client
parent14a6858a7d8bc085420a1430b3a3f67885019f27 (diff)
gentoo auto-resync : 29:08:2023 - 10:04:54
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/Manifest.gzbin3547 -> 3546 bytes
-rw-r--r--mail-client/alpine/Manifest1
-rw-r--r--mail-client/alpine/alpine-2.26-r3.ebuild101
3 files changed, 102 insertions, 0 deletions
diff --git a/mail-client/Manifest.gz b/mail-client/Manifest.gz
index e39970bf8d93..15acfb7496eb 100644
--- a/mail-client/Manifest.gz
+++ b/mail-client/Manifest.gz
Binary files differ
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index b11926991c0b..eb23d8b5c290 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -4,4 +4,5 @@ DIST alpine-2.26-chappa-5.patch.gz 173031 BLAKE2B 8719d37fde313e190608489e6191d4
DIST alpine-2.26.tar.xz 7517628 BLAKE2B fe156974462dd566ac3fbe25cc54a1b2a480b3af46c8356356a97426f3e42495853efdbfeedc6173537dc150d90592c3fd9109e7d37f16738922a4205fd2f9df SHA512 359b5cb30be78a341b76c0475a2d5268b643788f14c9b5b9457af6748034e1d2e70fd7ddf59e5c59ad596a36d8a10afa9c41cbd74241c780b8575d8186168fd2
EBUILD alpine-2.26-r1.ebuild 2327 BLAKE2B 929d810868a2580e59aedb0ba15d01a9cc46b70db24908a55458ed5cc1cf52296d3a33442d1c96e39f2929779ae6e1f5543694a989dfe3c457c87a787364728d SHA512 95c4489a833725470d8eee34ee8e301da67ef39bb0029bb4f9efe78ff8af30b93c469dd5fe11fd6a0b68d1ee8e55ec4eba9160d78a4d28a99590c3fe2d9e796c
EBUILD alpine-2.26-r2.ebuild 2487 BLAKE2B 986c0421e6eff3602656f1ddb11b9829dde0904d283d86e6509b0388c14dc3fda315b65febf08f7702829f081ac1390da4cd1fd13605e615fdf7b4163ca22ec6 SHA512 61d3d8e84c7df1cad4d38cd4ebdde354f583937e8ece9aecf8a1ccdd888c3cb451b7c9f714fa1aead11289bd498d712f0b8db72582fbe4c60f1dd8619905a35f
+EBUILD alpine-2.26-r3.ebuild 2731 BLAKE2B bf3192563182a8c5e91a2f508b3f4823f91e0ded7f4390d9d7aa4ad8b05eae94b78327a7fbf1603d01c4f804666a18f983fa4c4f4275992ed1767a129574ae47 SHA512 856fca2bce573109ad1b7e0d681e046e48dab1823f85a6ff49eced1a698127bb41c2c1e1c1ddfc6b3ce6a99fb9bf153ef4a2e101a76973511cee02556b595c06
MISC metadata.xml 762 BLAKE2B 026faecac5042e19cce6f125f66fd7af22cbd50140abe315a686d1b129f53b939f5325f9bd1956d41b47da146b6f37c597fe91370722f2f4c7af8169cbcb0f66 SHA512 e11cb2d6c0612fc09302485c38d216245adcabde36fb2c6e829b452f10f3adc9037f1461305e2e3cc3e89025560ac3d621b90b94eea152c9c3e0c53a6c6f9512
diff --git a/mail-client/alpine/alpine-2.26-r3.ebuild b/mail-client/alpine/alpine-2.26-r3.ebuild
new file mode 100644
index 000000000000..0a3624b42955
--- /dev/null
+++ b/mail-client/alpine/alpine-2.26-r3.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic optfeature toolchain-funcs
+
+DESCRIPTION="An easy to use text-based based mail and news client"
+HOMEPAGE="https://alpineapp.email/ https://repo.or.cz/alpine.git/"
+CHAPPA_PATCH_NAME="${P}-chappa-5.patch"
+SRC_URI="https://alpineapp.email/alpine/release/src/${P}.tar.xz
+ chappa? ( https://alpineapp.email/alpine/patches/${P}/all.patch.gz -> ${CHAPPA_PATCH_NAME}.gz ) "
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+chappa ipv6 kerberos ldap nls onlyalpine passfile smime ssl"
+
+DEPEND="sys-libs/ncurses:=
+ virtual/libcrypt:=
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap:= )
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+"
+
+src_prepare() {
+ default
+ use chappa && eapply "${WORKDIR}/${CHAPPA_PATCH_NAME}"
+ if use chappa; then
+ eapply "${FILESDIR}/${PN}-2.26-fix-clang16-build.patch"
+ else
+ eapply "${FILESDIR}/${PN}-2.26-fix-clang16-build-no-chappa.patch"
+ fi
+ eautoreconf
+ tc-export CC RANLIB AR
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+}
+
+src_configure() {
+ myconf=(
+ --without-tcl
+ --with-pthread
+ --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+ --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+ $(use_with ldap)
+ $(use_with ssl)
+ $(use_with passfile passfile .pinepwd)
+ $(use_with kerberos krb5)
+ $(use_enable nls)
+ $(use_with ipv6)
+ $(use_with smime)
+ )
+
+ if has_version "app-text/hunspell"; then
+ myconf+=( --with-interactive-spellcheck=/usr/bin/hunspell )
+ elif has_version "app-text/aspell"; then
+ myconf+=( --with-interactive-spellcheck=/usr/bin/aspell )
+ fi
+
+ if use ssl; then
+ myconf+=(
+ --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+ --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+ --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+ )
+ fi
+
+ # problems with strict prototypes, not easily patched #870766
+ append-cflags -Wno-error=strict-prototypes
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ # the bundled c-client lib stumbles with both -j>1 and --shuffle #888709
+ emake -j1 --shuffle=none AR="$(tc-getAR)" c-client
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/man1/alpine.1
+ else
+ emake -j1 DESTDIR="${D}" install
+ doman doc/man1/*.1
+ fi
+ dodoc NOTICE README*
+ dodoc doc/brochure.txt
+ dodoc -r doc/tech-notes/
+ newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
+ newdoc "${S}/doc/mime.types" mime.types.sample
+ docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
+}
+
+pkg_postinst() {
+ optfeature "Spell checking" app-text/hunspell app-text/aspell
+}