summaryrefslogtreecommitdiff
path: root/mail-client/s-nail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /mail-client/s-nail
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'mail-client/s-nail')
-rw-r--r--mail-client/s-nail/Manifest3
-rw-r--r--mail-client/s-nail/metadata.xml23
-rw-r--r--mail-client/s-nail/s-nail-14.9.13.ebuild91
3 files changed, 117 insertions, 0 deletions
diff --git a/mail-client/s-nail/Manifest b/mail-client/s-nail/Manifest
new file mode 100644
index 000000000000..d4cec66a5c15
--- /dev/null
+++ b/mail-client/s-nail/Manifest
@@ -0,0 +1,3 @@
+DIST s-nail-14.9.13.tar.xz 734416 BLAKE2B b23de9c32357d5b88ecb723dc875d3366b2b4c57dd654a4f2422e8bb81b781a76568eb0955990d4166f034bf40459fa5d2992da6e7f2b403a641a4d4c0c1e200 SHA512 6467846fab5752c708886ba7a66cd2038effc0cf8d72e2feb670283cf1d5436c27037087eeaa201c074964476ff0c213cffe74169fb03089ebf964fcc766e6ea
+EBUILD s-nail-14.9.13.ebuild 1935 BLAKE2B d6a22d55c96af91e1d73527421e0e4330f120eaf616647f6584022322e5d43bda9d440376829321d4aa5c449453711ea1937fd0749e2d807deaa57b1ee990be6 SHA512 bd5093554a5467ec80e1fe391123f32799487ef9a90823b891199c443db19928e646b6eb01adf5600638ae8d5b1310b557a7d6f05cc6e716d4ce3261942bb6b2
+MISC metadata.xml 827 BLAKE2B 60255cc3fe6eacd232600dc62ec110994d63025c0a378dc0853cf6111ec087859274a158e1a9719ae7853eb0b752e806b1c3ad3304256cba2c75ad21a7bda059 SHA512 0c0d5ece2c20d666bca54d14288ecf0bf61fcb7c3d0b65145c77f353f24382c35643eae9ac7b6d48657b795dbdbe7256d8b0ad4dcf54c55888cc289ed9e67d55
diff --git a/mail-client/s-nail/metadata.xml b/mail-client/s-nail/metadata.xml
new file mode 100644
index 000000000000..6fa99b2c089c
--- /dev/null
+++ b/mail-client/s-nail/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grknight@gentoo.org</email>
+ <name>Brian Evans</name>
+ </maintainer>
+ <use>
+ <flag name="net">
+ Enable support for network protocols (POP, IMAP and SMTP). If you
+ only need to send mail with the local Transport Agent, disabling
+ this will get you support for only /usr/sbin/sendmail call.
+ </flag>
+ <flag name="ssl">
+ If network is enabled, this adds support for S/MIME and
+ SSL/TLS-powered protocols through <pkg>dev-libs/openssl</pkg>.
+ </flag>
+ <flag name="kerberos">
+ If network is enabled, this adds support for GSSAPI login on IMAP
+ through <pkg>virtual/krb5</pkg>.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/mail-client/s-nail/s-nail-14.9.13.ebuild b/mail-client/s-nail/s-nail-14.9.13.ebuild
new file mode 100644
index 000000000000..2155941b9356
--- /dev/null
+++ b/mail-client/s-nail/s-nail-14.9.13.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+HOMEPAGE="https://www.sdaoden.eu/code.html"
+DESCRIPTION="Enhanced mailx-compatible mail client based on Hierloom mailx (nail)"
+LICENSE="BSD BSD-4 ISC RSA"
+
+SRC_URI="https://ftp.sdaoden.eu/${P}.tar.xz"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="idn kerberos libressl net ssl"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ virtual/libiconv
+ idn? ( net-dns/libidn2 )
+ net? (
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ kerberos? ( virtual/krb5 )
+ )
+ !mail-client/mailx
+ !net-mail/mailutils
+ !mail-client/nail
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local confopts=(
+ CC=$(tc-getCC)
+ EXTRA_CFLAGS=-std=c99
+ strip=/bin/true
+ OPT_AUTOCC=no
+ VAL_PREFIX="${EPREFIX}"/usr
+ VAL_SYSCONFDIR="${EPREFIX}"/etc
+ VAL_MTA="${EPREFIX}/usr/sbin/sendmail"
+ VAL_MAIL='/var/spool/mail'
+ VAL_PAGER=less
+ $(usex idn VAL_IDNA=idn2 OPT_IDNA=no)
+ VERBOSE=1
+ )
+
+ if use net; then
+ confopts+=( OPT_TLS=$(usex ssl require no)
+ OPT_GSSAPI=$(usex kerberos require no)
+ )
+ else
+ confopts+=( OPT_SOCKETS=no )
+ fi
+
+ tc-is-cross-compiler && confopts+=( OPT_CROSS_BUILD=yes )
+
+ emake "${confopts[@]}" config
+}
+
+src_compile() {
+ emake build
+}
+
+src_install () {
+ # Use /usr/sbin/sendmail by default and provide an example
+ cat <<- EOSMTP >> nail.rc
+
+ # Use the local sendmail (/usr/sbin/sendmail) binary by default.
+ # (Uncomment the following line to use a SMTP server)
+ #set smtp=localhost
+
+ # Ask for CC: list too.
+ set askcc
+ EOSMTP
+
+ emake DESTDIR="${D}" install
+
+ dodoc INSTALL NEWS README THANKS
+
+ dodir /bin
+ dosym ../usr/bin/mailx /bin/mail
+ dosym s-nail /usr/bin/mailx
+ dosym mailx /usr/bin/mail
+ dosym mailx /usr/bin/Mail
+
+ dosym s-nail.1 /usr/share/man/man1/mailx.1
+ dosym mailx.1 /usr/share/man/man1/mail.1
+ dosym mailx.1 /usr/share/man/man1/Mail.1
+}