summaryrefslogtreecommitdiff
path: root/mail-client/roundcube
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /mail-client/roundcube
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/Manifest2
-rw-r--r--mail-client/roundcube/roundcube-1.3.9.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index b0520336ff33..be65c6269d8c 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,5 +1,7 @@
AUX POST-UPGRADE.txt 1020 BLAKE2B 40e8eb52fcb1c7b46843a136e1617c825e6cb2dc9031f225635ceb19a2c7f4aafd1f4baf7fadc033514da429c7f6893bd6950ef09fb55570db60267ddc5f7219 SHA512 45b3fd6d2323ac8b43117908385c9ebb681b59b3f77aa516074d13196a259d9614369eeb1a8969fa514555e7240846c2d85502b8a9fed9a31a0379b1086861c1
AUX roundcube-1.3.7-pear-removed-installed.json 6981 BLAKE2B 3caa7d2d18f4fdda2d5ec6cdbc78f4f8fc6a55b176ab6f3158cd6ad930581b2ee291d7fb7f01bf20e9ff9e6bc9bed3b677575ef23cf4023fd27658cbf97574dd SHA512 a49112c063b24757f12cebdfc6d2ab4e84842b33f622e8cea07fb9b248fdfdebce83a190b91bfa820a69e8f4c62bc7b37bc3663bf1761216eed99c3f463fd69b
DIST roundcubemail-1.3.8-complete.tar.gz 5534385 BLAKE2B 2f0cb528d0901d267c74d57baa18d1f057fdd2eb0f872f3cef1053847861998f8c6551fc17506ae365086ed1f86c3ee9e73a96adb2e43c6c32025e7afaf63710 SHA512 34dc9205cd93be6d6551086f4d22654dad7213b4b09000dc4def08357acdc634744ce1f560144a3d3b46e936258e90482e77fc4c691a55c205bcfdfe3745441e
+DIST roundcubemail-1.3.9-complete.tar.gz 5521697 BLAKE2B 4689bb43ff02b99a9b2b06d6370a5dce0ec4eca4e4da2a74e33e77ec74ec14bf22b6bab415c8b5fde9bd76bfaed87f183a8979edb353da3ed947f9bfdb0ecb15 SHA512 42ae9b772272b3e82476beeeb0fc5a909fb07ed0bfbdb655627b1e31da1c292f67f5a305452de31b2d60fe5905bcacabd6874dea394a9b0fd66b7921d73500ac
EBUILD roundcube-1.3.8.ebuild 2426 BLAKE2B 3028d0e6f300d6eaa7d1cda1ec854b2a3f1149dc5a56e29a89a4de71e3e4b1f2f8d927f5f89cc202e78dfa34d603f58430aee493c03c11cfb9edd7636503b298 SHA512 60d2e8bbf22312f9f81a6ade6628e7ed67ca771ba914e8045cabd2786941c13fb0b363575d6b2edfb9f847e92f255b0441535d12655f08588fd479611e2eca9a
+EBUILD roundcube-1.3.9.ebuild 2432 BLAKE2B ebda963ec305ebeab3345e343e59e6994dd4c91115ac37bc19dca2b0b47ae5796b2594cc09df8b52c476f8d6fa5120dc4917ac2b302cddea931ea07c16972ae6 SHA512 8b3cc79dfb46a75c61aa6b22bc3f7f7bab50c7c80abcb4c6023a98bb45d98aaf67416468eadec8e91979e2dd72462f0da3f3a91838326e0bab6f213217cebbd3
MISC metadata.xml 955 BLAKE2B ca9dd109384433cdaca59b820aae795a4555459cf36f057b17949d601bd5ece8222dbb59502872ac6a16387e55839f859b91a6c6718523aaf66e4b677d25d33e SHA512 ff1b796f79f002814b038763305a404ee2b65d49346a10b423dc8df982ccd4116548c8159bbcd551ccdcdb5824ef6b0774abf6a6bdc851beb896f6e5ed97bf1a
diff --git a/mail-client/roundcube/roundcube-1.3.9.ebuild b/mail-client/roundcube/roundcube-1.3.9.ebuild
new file mode 100644
index 000000000000..05e90ad0304f
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.3.9.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${PV}/${MY_P}-complete.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="change-password enigma ldap managesieve mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+# :TODO: Support "endriod/qrcode: ~1.6.5" dep (ebuild needed)
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
+ >=dev-php/PEAR-Auth_SASL-1.1.0
+ >=dev-php/PEAR-Mail_Mime-1.10.0
+ >=dev-php/PEAR-Mail_mimeDecode-1.5.5
+ >=dev-php/PEAR-Net_IDNA2-0.2.0
+ >=dev-php/PEAR-Net_SMTP-1.7.1
+ virtual/httpd-php
+ change-password? (
+ >=dev-php/PEAR-Net_Socket-1.2.1
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ >=dev-php/PEAR-Crypt_GPG-1.6.0
+ app-crypt/gnupg
+ )
+ ldap? (
+ >=dev-php/PEAR-Net_LDAP2-2.2.0
+ dev-php/PEAR-Net_LDAP3
+ )
+ managesieve? ( >=dev-php/PEAR-Net_Sieve-1.4.0 )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Redundant. (Bug #644896)
+ rm -r vendor/pear || die
+ # Remove references to PEAR. (Bug #650910)
+ cp "${FILESDIR}"/roundcube-1.3.7-pear-removed-installed.json \
+ vendor/composer/installed.json \
+ || die
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT%/}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}