summaryrefslogtreecommitdiff
path: root/mail-client/roundcube
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /mail-client/roundcube
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/Manifest2
-rw-r--r--mail-client/roundcube/roundcube-1.4.9.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 5635ddc0cd88..6caae6e9e090 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,4 +1,6 @@
AUX POST-UPGRADE_complete.txt 854 BLAKE2B e99a1ec9a316c90ee4adc112dd87f394d0e2ce37ca5d1195e3f812683a2da59bedf45688cd448cc3ca544a02ee1c0e125f3960e81a062b0f7949e2cde581563d SHA512 0328842265ca859e78fa7d5babeac7b6baa16fb25962f50d431bbca133d042694d98942f77ba3387832d66645cc4df8fb9f3c4591ca7ed4eade6782a92a3d445
DIST roundcubemail-1.4.8-complete.tar.gz 7032822 BLAKE2B 61c5329d9abe65baba3274d3cb9a6a435f886a0196c2881153da473eb415ad4c63dfdab49c67c75a2fd92ff55f9e6da7bdfcece7041ce408b2be628da47045d4 SHA512 8b7734cdec95954b7e18a0e44957da6ef74b5b0c3d28a1449e8634faa230844f5e0c28954245641758f8b2d9102aa32f279765ed3dfa20fa7b00dee4e5347362
+DIST roundcubemail-1.4.9-complete.tar.gz 7043437 BLAKE2B a1b7c6e160d29f61e2ca9c25f725b55411cb52c0f0d00fc4b3dc2ab1eb0edf190176ec932a297d6052b34047673e5dfb8cb13ad3a7b8b755e9d8e9265fb85aa9 SHA512 c6395757544b85693e808234f3dc6baac618ba115fb2c9eefc309ee18e74b2fdfbc0af00ac2b3b980fdd2abc56eefde47b535cdf688cfd2a5ce975786aca6572
EBUILD roundcube-1.4.8.ebuild 1792 BLAKE2B 6ee68871faba7e25719ea805518faf117e5619cc265235e7df8189d557af0fbc48b4c1ee14f1241854e64bae810f05679d6a154a209795c2738fcd8e5f7b3626 SHA512 60ecc662e19e21ba510947dcb07db3dd62912f675ca9b5c1a4502df456d6be8109c7803b8e4322b307ca9daa28cc70ab39f037b7f290e14e96fa1c2539cb1862
+EBUILD roundcube-1.4.9.ebuild 1798 BLAKE2B e51db73005c7b8a1c2a501566efe426b7cbf4e8079149546ede7e520e528ef6c4743eb6c75ee674ea65ee69ebd25ebfdde023c1e248fd9e7c21f3b9a8a345db2 SHA512 f6ae8f889cd6a17f0367ebe6f4bac62eac7a43bb410d141a2fa7f68307315bb2b2f61319a0b1519af620a8d3aa17deb2a9fc3580c86c6a701ab5c6aeb304b54b
MISC metadata.xml 888 BLAKE2B 08166287c0fc134f79884a6bd5cf96d67ab12a74422393d0ef8b4c89b588911e03d587f99bc62bff132494d021fc03b79fbe25a3a7e19ac9ae3107495f2d45c5 SHA512 c5522fd989d08c1de91aac7783e7fb8cbdf94669ca645357b58b3565ed604a52bf563d6417f28b6e2833ad51ee65ec4dfb76412ba88e1b280e346ad8d35b4f86
diff --git a/mail-client/roundcube/roundcube-1.4.9.ebuild b/mail-client/roundcube/roundcube-1.4.9.ebuild
new file mode 100644
index 000000000000..6d3b3ede4e45
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.4.9.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="change-password enigma ldap mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT%/}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}