summaryrefslogtreecommitdiff
path: root/mail-client/mutt/mutt-1.9.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-10 17:26:49 +0100
commit6957f5c65b02bba533954eabc0b62f5de36be206 (patch)
tree21d8ab8f61dffd9cccc82d0badb68982516a6855 /mail-client/mutt/mutt-1.9.4-r1.ebuild
parente91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (diff)
gentoo resync : 10.04.2018
Diffstat (limited to 'mail-client/mutt/mutt-1.9.4-r1.ebuild')
-rw-r--r--mail-client/mutt/mutt-1.9.4-r1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/mail-client/mutt/mutt-1.9.4-r1.ebuild b/mail-client/mutt/mutt-1.9.4-r1.ebuild
index 158b60319d21..3a03f9c5bfda 100644
--- a/mail-client/mutt/mutt-1.9.4-r1.ebuild
+++ b/mail-client/mutt/mutt-1.9.4-r1.ebuild
@@ -15,8 +15,9 @@ SRC_URI="ftp://ftp.mutt.org/pub/mutt/${P}.tar.gz
https://bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz
https://dev.gentoo.org/~grobian/distfiles/${MUTT_G_PATCHES}"
IUSE="berkdb crypt debug doc gdbm gnutls gpg gpgme +hcache idn +imap kerberos libressl +lmdb mbox nls nntp notmuch pgp_classic pop qdbm +sasl selinux slang smime smime_classic +smtp +ssl tokyocabinet vanilla prefix"
+# hcache: allow multiple, bug #607360
REQUIRED_USE="
- hcache? ( ^^ ( berkdb gdbm lmdb qdbm tokyocabinet ) )
+ hcache? ( || ( berkdb gdbm lmdb qdbm tokyocabinet ) )
imap? ( ssl )
pop? ( ssl )
nntp? ( ssl )
@@ -27,7 +28,9 @@ REQUIRED_USE="
kerberos? ( || ( imap pop smtp nntp ) )"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# yes, we overdepend on the backend impls here, hopefully one day we can
+# have REQUIRED_USE do what it is made for again. bug #607360
CDEPEND="
app-misc/mime-types
@@ -171,13 +174,15 @@ src_configure() {
myconf+=( "--without-wc-funcs" )
fi
- # REQUIRED_USE should have selected only one of these
+ # note: REQUIRED_USE should have selected only one of these, but for
+ # bug #607360 we're forced to allow multiple. For that reason, this
+ # list is ordered to preference, and only the first is taken.
local hcaches=(
- "berkdb:bdb"
- "gdbm"
"lmdb"
"qdbm"
"tokyocabinet"
+ "gdbm"
+ "berkdb:bdb"
)
local ucache hcache lcache
for hcache in "${hcaches[@]}" ; do