summaryrefslogtreecommitdiff
path: root/mail-client/alot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /mail-client/alot
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'mail-client/alot')
-rw-r--r--mail-client/alot/Manifest1
-rw-r--r--mail-client/alot/alot-0.7-r1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/mail-client/alot/Manifest b/mail-client/alot/Manifest
index 9d238df6333b..969d6ce8ab8e 100644
--- a/mail-client/alot/Manifest
+++ b/mail-client/alot/Manifest
@@ -6,5 +6,6 @@ DIST alot-0.7.tar.gz 1539283 BLAKE2B 33e77f815c4f83fc08f1834a89a984309c1d4b89454
EBUILD alot-0.3.7-r1.ebuild 1824 BLAKE2B 30ff26b9847099731b551c48da9e0c47f73168628ab156c0d596ecb11a4f1b672013c988e6a291e68647f7a7dd6c1bcbc89f5126c9f252457b8b76bb10189201 SHA512 b422278386cdfdc4ad1c4e853945ed680428b1cce9ca11ac251733aa86269515cf66320feedb1dcc8afb3b85145c45f9c2325e94b8968cb184df2ff4161961ae
EBUILD alot-0.5.1.ebuild 1966 BLAKE2B f4dd9063838c3d31fff83943c86d1f1e926b87e1f3163fb4ff8df6dc5de13693267391b2101aaaca69092fb9cb6f953ac50a42d967411eb5ab89b45bfbf623b3 SHA512 6ff16a9eed4fdf2c713bd249b969d3e8f70b4821d81224f1f2b910abceb2b899d6ac1a75c9dbfaefb6ff863a2500ef7b3ae3a64f16c04ece5433894f3b0039e5
EBUILD alot-0.6.ebuild 2438 BLAKE2B 9f69b9206b295f58d37e4501688256e05cd7a1475cb99a7421a73bd21189fa009db9c69906184ce8cf144eea15d2afc1e542489d072552f819c0eb70b8175058 SHA512 2f88e6e868ffeeed30f3ddc03998d24931c60ff6a64944b3baca132169db7b57cbca945215f167d6d7ce9aa3320eaa23db1378379eb59705d755a93ecf9b7855
+EBUILD alot-0.7-r1.ebuild 2424 BLAKE2B 0c35c0e08d7f1ec46e2271414a4a4eed65d64be26499dffaa6fc637e32a213726be0a0d80f4349bb299ceb6bd19fff308f93fd5c749f31630d46c96101038251 SHA512 8051ca5d2b216375f1c60eb07b51e517942a428ef75546c904f5cac58be0a0a0f25a4814a1a9c9b6fdea74ccfb82cbf47d7a291e14296529536843b181b9711d
EBUILD alot-0.7.ebuild 2438 BLAKE2B 6206adf16196557e1ffd817bfed0e846f544e4eb21272f7aac3fed4fd1c184da38851f44f4b62d9de0d6a472d2eab3a7540795be242e5cb0bb5869b6ae466719 SHA512 f84b6e2fa31aa8ce916995248c8b04971fc5c0bbdf20242a84ddf33f3e2a5fb7ed9a87ffa31883263a70dcb5668c947fcb94dc3c0b463a1877c205af1e2fa242
MISC metadata.xml 595 BLAKE2B 3224d20978831a7a42fd43f4feba8970d2faa44de4b956e3a893759df9b9425fc0dc788928650e868d224b2319fd1df222c8e2c7eb8c1662cbb5af53d4291dee SHA512 a4017c9bec2be65464948cff90cfd9fd658337abd527dc86d59c08128d373626b34d583f038693c7ca5f39997f34bda26d890cdd129891a96cc88d3ee953aca7
diff --git a/mail-client/alot/alot-0.7-r1.ebuild b/mail-client/alot/alot-0.7-r1.ebuild
new file mode 100644
index 000000000000..55e4adc56b62
--- /dev/null
+++ b/mail-client/alot/alot-0.7-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="https://github.com/pazz/alot/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/configobj-4.7.0[${PYTHON_USEDEP}]
+ >=app-crypt/gpgme-1.9.0[python,${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/urwidtrees-1.0[${PYTHON_USEDEP}]
+ net-mail/mailbase
+ >=net-mail/notmuch-0.13[crypt,python]
+ "
+
+python_prepare_all() {
+ find "${S}" -name '*.py' -exec sed -e '1i# -*- coding: utf-8 -*-' -i '{}' +
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/alot
+ doins -r extra
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ echo
+ elog "If you are new to Alot you may want to take a look at"
+ elog "the user manual:"
+ elog " https://alot.readthedocs.io/en/latest/"
+ echo
+ else
+ local rv
+ for rv in ${REPLACING_VERSIONS} ; do
+ if [[ "0.3.2" == "${rv}" ]]; then
+ ewarn ""
+ ewarn "The syntax of theme-files and custom tags-sections of the config"
+ ewarn "has been changed. You have to revise your config. There are"
+ ewarn "converter scripts in /usr/share/alot/extra to help you out with"
+ ewarn "this:"
+ ewarn ""
+ ewarn " * tagsections_convert.py for your ~/.config/alot/config"
+ ewarn " * theme_convert.py to update your custom theme files"
+ break;
+ fi
+ if [[ "0.5.1" == "${rv}" ]]; then
+ ewarn ""
+ ewarn "Since 0.6 version the GPG engine has switched to app-crypt/gpgme"
+ ewarn "to use GPG signing operations, you can pass the key id has arg"
+ ewarn "or setup the gpg_key value in your config file, see"
+ ewarn " https://alot.readthedocs.io/en/latest/usage/crypto.html?highlight=gpg"
+ ewarn ""
+ break;
+ fi
+ done
+ fi
+}