summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-runner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /lxqt-base/lxqt-runner
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'lxqt-base/lxqt-runner')
-rw-r--r--lxqt-base/lxqt-runner/Manifest2
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-runner/Manifest b/lxqt-base/lxqt-runner/Manifest
index 00e60155d510..612b63ee4dd7 100644
--- a/lxqt-base/lxqt-runner/Manifest
+++ b/lxqt-base/lxqt-runner/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-runner-0.17.0.tar.xz 225672 BLAKE2B 114ef09d79edab21fe5320eb8c94e63ed491e7ee5063d69d6ae726ff482a52805e792060cf308811567aa92c24802f7524a736e05caceafc6886df3d27c8add8 SHA512 cafb6c722c803f9f3e1902e7fb3945c7028ec0bdc22b46d7fc0cc0cc305dea8da8c9098baf97e2db30fa82d88d9d59805e403eacadc6d2b311d1b289cde2ad74
+DIST lxqt-runner-1.0.0.tar.xz 226548 BLAKE2B b17ec364ca06a5b67341dca5db2c6ffaf85211b428027afe13224d18a53ef1829ffb7006c8a47317676e43f8ccc3e473973411c415be9a4315fa5e2cb5343791 SHA512 1af796a7e81108c223290d978a6503cc357cebbea19e3b4b3cf01a2fbc1d42cad7ab03a5b609677ddccc0afaf1de4f5433f5fea13315e3f717bdfdee0e2ced1a
EBUILD lxqt-runner-0.17.0.ebuild 890 BLAKE2B 050fffba599b53dc825817dd92a0998b45069cfda27cd7e184165b1232dc6dc769c8ca3b89ed141d1100345e49c620fd9f02738f86cde999de9054152487df65 SHA512 670b788265a4981b8cd9950c99e279a375ebc8cab292cad3457885da0fefb29e9c5ba51f425f369cc8958302a7fa870964eb8cee3b8a1c6a089727cd11745369
+EBUILD lxqt-runner-1.0.0.ebuild 931 BLAKE2B 20ceebe3ce39f7007b36afa51d5e2964a4bd8d0283c46a7f674e0846d83fe7c938e3cc8040da52d3cf00c6b44d440a6dd806d6f537763667133830b8c3705944 SHA512 3f98139bd2ea1471346c78d42102ca504a2b2b23aa433963c7b014e0aef58754d0a2c8cc5dcdc9e1973ee947c39360d38cf99af8d3e1e832bfa842212255bb59
MISC metadata.xml 318 BLAKE2B 71a6dd14bc178376682505f23c51b445c52665d98b7acc8d69fb65fc7c34b1142d4df7b88d704d2bceb3c6f65f92305cc040957b86a19102cbd42b327f0ca108 SHA512 f602edf93e4a0cbd8b27dc9bc893cbbf0e40aa226df6becfd3aa8dff8b63e4f215888a91c961de5bf6cc89f29f0fad9c17a177f77c8f68fee18362c7c391221b
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild
new file mode 100644
index 000000000000..ee01c78c8294
--- /dev/null
+++ b/lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt quick launcher"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.10.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-cpp/muParser-2.2.3
+ >=dev-libs/libqtxdg-3.3.1
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtxml-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ =lxqt-base/lxqt-globalkeys-${MY_PV}*
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}