summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-policykit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /lxqt-base/lxqt-policykit
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'lxqt-base/lxqt-policykit')
-rw-r--r--lxqt-base/lxqt-policykit/Manifest2
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-1.0.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/Manifest b/lxqt-base/lxqt-policykit/Manifest
index 7194955836b7..fb544481b61c 100644
--- a/lxqt-base/lxqt-policykit/Manifest
+++ b/lxqt-base/lxqt-policykit/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-policykit-0.17.0.tar.xz 38272 BLAKE2B e141d0ff7a583b22ddddcde3875cf82a5215cef0c6270774b3b31e21608f16bc78dd45b3b36b8ba1fde3bbeda30b2f638a47ecf7dee1797da151cb701fecc866 SHA512 1cfd4b2d21840704e4b15ae71098e9c6f3d51031293f1fdf6e134ffee867fe4e845caaf24fbd2c107317372b90b6d415a76854977fa8f6b703e708bd09120328
+DIST lxqt-policykit-1.0.0.tar.xz 39040 BLAKE2B 0bbf68cd6ad4edf9c2553332855099317a852174baa7ef42e47c50d8a37eb8f87caa8f7698a84de9ed14d8c6afda3be93cef5113ec7019583345acdfcd82e5ad SHA512 c0d7c5ff8a5e95e74eefd094625d71603026e9d30c033e224fc4e62eba63f1bfe76ddf666eb1875a14c2c1bea3d21e4ac6d191e90bc2442f7e4e62845a63a3f0
EBUILD lxqt-policykit-0.17.0.ebuild 819 BLAKE2B 15f1ebc555976c2ee2b60d15abc9e69ad7d6cce3b88af980e29b184cbed88ddd10e729d2dacbeb3c35235de5feaf049d99cc8cc145e35c73250799d9d762c350 SHA512 21eacb96d87bdbc6f72abf3d56b62592ef9869fa56214c873b89e8e1a8618732681603a0a9e22a3289960862f97ff1ca85e067d4a307f72402ec9704f3248b66
+EBUILD lxqt-policykit-1.0.0.ebuild 828 BLAKE2B 4992ae1f91940a7efd42937ce278b58a61c8766d25d521ced0ec51f32f031da532afc7bd136c1cfc14e7053b641949e76da98dba1ca49e6660cc59e55876c025 SHA512 d155a79491da46320d0a0b8ce6ef49367877d8cad7db82d03dd694b151497f8f9be668fe043ec2faa2a1e364baede61993d75bb17c7fa75e9c841df09dab32bd
MISC metadata.xml 321 BLAKE2B 749c440c7f991f5082d78a5b7caf74b61aa40653611cef2fd1a10991dcae8c170ae1535eb0e298865f70fc06dc2ae5c6d6d8243644a421dd3f36c73ddc6fde37 SHA512 ded23c529e8f5ff9f7fb1ac11b0c0f128ad7294ea890d35d3b30c8ed0c7866c8f65bac504f8d790cabd986f40a4450e46370b5b72881272e55c51207f1e703d6
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-1.0.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-1.0.0.ebuild
new file mode 100644
index 000000000000..450daf49d66a
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.10.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ >=sys-auth/polkit-qt-0.113.0
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}