summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-policykit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /lxqt-base/lxqt-policykit
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'lxqt-base/lxqt-policykit')
-rw-r--r--lxqt-base/lxqt-policykit/Manifest2
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-1.1.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/Manifest b/lxqt-base/lxqt-policykit/Manifest
index f04f5176ca79..33a56f466f19 100644
--- a/lxqt-base/lxqt-policykit/Manifest
+++ b/lxqt-base/lxqt-policykit/Manifest
@@ -1,5 +1,7 @@
DIST lxqt-policykit-0.17.0.tar.xz 38272 BLAKE2B e141d0ff7a583b22ddddcde3875cf82a5215cef0c6270774b3b31e21608f16bc78dd45b3b36b8ba1fde3bbeda30b2f638a47ecf7dee1797da151cb701fecc866 SHA512 1cfd4b2d21840704e4b15ae71098e9c6f3d51031293f1fdf6e134ffee867fe4e845caaf24fbd2c107317372b90b6d415a76854977fa8f6b703e708bd09120328
DIST lxqt-policykit-1.0.0.tar.xz 39040 BLAKE2B 0bbf68cd6ad4edf9c2553332855099317a852174baa7ef42e47c50d8a37eb8f87caa8f7698a84de9ed14d8c6afda3be93cef5113ec7019583345acdfcd82e5ad SHA512 c0d7c5ff8a5e95e74eefd094625d71603026e9d30c033e224fc4e62eba63f1bfe76ddf666eb1875a14c2c1bea3d21e4ac6d191e90bc2442f7e4e62845a63a3f0
+DIST lxqt-policykit-1.1.0.tar.xz 39280 BLAKE2B 190ab41a7de867cceff0b363b0474466e5740dbcfbd5342678d839058d8791e19799363ea34ca7b0a90e14b6d687f571c4d044f51a539f1431e57c603844a7fd SHA512 41592a2f086c5308ed71ef856bba8c3f81aa392700696e8a82554ce049bec07f41221a9862244d22f732b8f09a7c157596a50ef48bd30f1acf491317c4e21d12
EBUILD lxqt-policykit-0.17.0.ebuild 819 BLAKE2B 15f1ebc555976c2ee2b60d15abc9e69ad7d6cce3b88af980e29b184cbed88ddd10e729d2dacbeb3c35235de5feaf049d99cc8cc145e35c73250799d9d762c350 SHA512 21eacb96d87bdbc6f72abf3d56b62592ef9869fa56214c873b89e8e1a8618732681603a0a9e22a3289960862f97ff1ca85e067d4a307f72402ec9704f3248b66
EBUILD lxqt-policykit-1.0.0.ebuild 825 BLAKE2B dff76e114b98de31fb596b356d25d564b79acd71294def0412d07009b3c47c0afd94d352379236df80f37b64faf9931c8598a0c0d4367dcb7e81876400131665 SHA512 6e265206c736732019e5b5fdd35a25436e8286f5d90cfed6eccc91ba3800474c7bc2521b2521bd67382c33cef5f1a37c8d50d87976e952c83d5c4872a2ca236e
+EBUILD lxqt-policykit-1.1.0.ebuild 835 BLAKE2B 993bac4c2a68f0035309429881a3c5acaa18fd4f5719463ea4fd1b11805faad1a7602d3b40bf6aee8cffe973fff8f1eb0516e98b777cfd7fc4f754b79370d1ae SHA512 530091240a785abcc9bfda26519e6d1efec9c07323c294ebd9cbdb93ac7375ba53881c7201664042da5c725083f4fadb55034860c56d0126635ebc5033b66325
MISC metadata.xml 321 BLAKE2B 749c440c7f991f5082d78a5b7caf74b61aa40653611cef2fd1a10991dcae8c170ae1535eb0e298865f70fc06dc2ae5c6d6d8243644a421dd3f36c73ddc6fde37 SHA512 ded23c529e8f5ff9f7fb1ac11b0c0f128ad7294ea890d35d3b30c8ed0c7866c8f65bac504f8d790cabd986f40a4450e46370b5b72881272e55c51207f1e703d6
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-1.1.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-1.1.0.ebuild
new file mode 100644
index 000000000000..094d0509c016
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.11.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ >=sys-auth/polkit-qt-0.113.0
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}