summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /lxqt-base/lxqt-notificationd
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest2
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index fc1c2e532246..fde45953acf1 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-notificationd-0.17.0.tar.xz 53712 BLAKE2B d15f00179eb24c43add51f246b46738d4da6f9ce89f041a65ce4acc252ebd0a832519c0e9e7ac2ee86d23806a2ac6a9a740b57fc5e88d73a09d1170e405386ef SHA512 042d69e01c3015d254ae3472867de0b41587af2285cd26445cd9d6d455de8ef713413431dea9997f2d2e19f70c2c8c73af39ce880d54ecb9fd6c50cd05a7dba4
+DIST lxqt-notificationd-1.0.0.tar.xz 57160 BLAKE2B 518822c8fc4e5d8d68ae8181d64f80dc4dd0ffb7cc192f69432efaa7f35242c8e222b45cf51eaad473c8b55df09fd66475f7c1f9343d7d9b24c757304cef061a SHA512 e8953c06be5821d875027692589dd80bfc7bca8ff9d7e590dcab2ab80b17ed530983119b0cf9d254ba5b15bf863eb6283896e6ae38a999437e5ccd7d3a50adf9
EBUILD lxqt-notificationd-0.17.0.ebuild 753 BLAKE2B 44982070938597db7cb374a26adbdca496b63e0277b36be7593459b8ed3b1ffd9cc25d131e40340d61448b4548fa49f2332d7087c5c388ee6de9561601c31eb3 SHA512 5e5fd61a5d75a76129196f98a270a392675826555a4ecc3713feddcc277bd7c50150e3db145407322e66f6e0cbd31519c846406dea41faa8ca8fe10ffee82968
+EBUILD lxqt-notificationd-1.0.0.ebuild 806 BLAKE2B 5327768154f1e4d5812f2c269ccdc5c03b2812816559ea85372cc30cc7717c67c0803bb40b23a0b6965b30c986cac65d649ceadf1c84d8425918a578958bf858 SHA512 546857e4d8dc3926637e2631b61be030ab9cee904a7805a966497d3b42e539f6d0c55582f78ff6ce70bebaaf825f4e6245e07ec9523a57466c5015cddd68ba18
MISC metadata.xml 324 BLAKE2B 9a9ade6923097018d9e6caa51617b06c04df45227a4afbf512e04a54e2e5387f162c9b48483ff0f2fa9451a118f8b372bd1d3a487a0be2f3c896524611fe97c6 SHA512 252b5a4a24e16a6cc461670adafccb7041a8229414bd68e564ceadab8bd1ee7141fc43d8db9b6a04c161c947749c28e21815d40f49f44ea049a23167d408368f
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild
new file mode 100644
index 000000000000..9cbfbe3ee0d5
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.10.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"