summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /lxqt-base/lxqt-notificationd
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest2
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.16.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index 0d69e32d2d5d..885662a62e7e 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-notificationd-0.15.0.tar.xz 49068 BLAKE2B 00277a1ecb75a7591ad4d74156889f9fceec1f81b752f2d6dc10bc77a8dbe8406df88ff4b768dfa42efa3b50048fd757b648766fa7131f7e11b5314fc9718a9e SHA512 0febe3ff61caaf4303e3853df6bc494ce8eb4a931e6d8600a2e38c07317ecadbe3d7060ac234d139326a726c43ac555153dde6b2d4d05e95ab357873457c9632
+DIST lxqt-notificationd-0.16.0.tar.xz 50696 BLAKE2B e41528091c9c8abfbcd4de53daf753d5f031f9941a83c1e8c0a4f492dba85d1edd08185726dc3f68d0553c5f23a6f97a9835061bdad47abe98c4f0a54ec942f4 SHA512 127f1c044babb0c7a640d862fc9f30947b06ef37b702a75bc72a87f82f9aff15b32e29272993eb9d888e1c8db93e81cec8d07be515c769c560ecce4b439bb2f3
EBUILD lxqt-notificationd-0.15.0.ebuild 769 BLAKE2B 706565e61570b696608be5218f73d54dda00af157206cd108f666fec98692532c43eeee349674455a7e0cecc754561f38d2ae4347022662726d6bdab7e1229b8 SHA512 643f349328ba00378f754891d669e20babd0c531ac5ad802c25288c29f4b7651a9ab8f795a500a9f9c70102b152d00d15603c58732a5edab8cfcdb60eeb111fd
+EBUILD lxqt-notificationd-0.16.0.ebuild 771 BLAKE2B 7191d8fbeefacb83722b613c47a3b91c2532c608b4132035847055b647f1f0a73f461a9f072bffc10b43a3a094a1acd374b4ba621c0ea6b93ebc566d039bc6f8 SHA512 3432c66e7ec0bd3795c10f9851775a796905e30e7fae1ca40c1fa9ccf82426fa55d36d324d110ab4641965fd688b7af863820c88f9874d557f059ebcefe8bcdf
MISC metadata.xml 323 BLAKE2B cc28b17d478bed98b59743c03ceb630cc65495414d1dd5703b917643f54ff606518016358e2b0149cc25082097a1e8dd5cb2ee173c235aa6cc4197d9cc258493 SHA512 3aa6fb296384049f738b51edf21ea16a7a68cad1cf5bc79c6c34f970f12292afdb44eb34bf6b48c8e884903dfad041e1078b7409427aaeaabee48d5ee5c1bc14
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.16.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.16.0.ebuild
new file mode 100644
index 000000000000..21ead6b345b6
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.16.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"