summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /lxqt-base/lxqt-notificationd
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest2
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index c149372bebf9..7d4f2443195a 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-notificationd-0.13.0.tar.xz 32364 BLAKE2B c43e57e66e2fdd375f25afd68acc428c6204992e48c2b2bf1a692380bcb2f48663c52b3a5a9b17d01a68d6cb57e6779260da3c9e09873baa0a8c7489dfa9c9a7 SHA512 2bc75b840a666e013d914f08719680cf3af7430a6acfb5072facff8bdc964aeef1d5227c68b5a5c5d8a6d6c572632105e3f2f04c517d8e8669eb40b5a0cf0f4d
+DIST lxqt-notificationd-0.14.1.tar.xz 47356 BLAKE2B b80febe059a17e30df4abb81e6d63271b8955211474d80853dc54ea65112081160bf270766654498b50c78c58df4444682e1e9b9cac800c4afb294fdb2fdbaeb SHA512 dcd1892ff66d6beb5c8953c6731f798a59272365fb7439277732b145cc9e6479314415481d9e8aae9fd670d779011c3d7bb3874b05a67cfad2a722f467866795
EBUILD lxqt-notificationd-0.13.0.ebuild 847 BLAKE2B f31c338183d441a391e9a9ae68fc89232b40d8b91321c2bd0d81aee0b3167a9a1630e3d61990a6d4ee95af100d43a2b8baa0295fd3f4a15c5988d6ba27345752 SHA512 a5af9a095db555bd09af0cf2fefd83758e8950dcb7db9429b1138d2e647824eaf4921d235ea070280fdee96f0bd3db95a3379cb60795f2d0b73f13b1f40e9750
+EBUILD lxqt-notificationd-0.14.1.ebuild 750 BLAKE2B c25ffaed20427bf29713e80ac72e638cbffbae4d0e2601a21142786ef44c41b71cf2a6d59a478bd7855b103f7853546707063ac2039be2cc08236440fb74bd12 SHA512 b6369cd78b66ca027718da7f17b8ec6beca27c98c0b2157589f379fb4170cdff77567e20c20436bb598ca37b80fe68b1eb3d7a49514fd8d64df398ab1848644b
MISC metadata.xml 323 BLAKE2B cc28b17d478bed98b59743c03ceb630cc65495414d1dd5703b917643f54ff606518016358e2b0149cc25082097a1e8dd5cb2ee173c235aa6cc4197d9cc258493 SHA512 3aa6fb296384049f738b51edf21ea16a7a68cad1cf5bc79c6c34f970f12292afdb44eb34bf6b48c8e884903dfad041e1078b7409427aaeaabee48d5ee5c1bc14
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild
new file mode 100644
index 000000000000..5b510c9b2b27
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.14.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"