summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
commit6147e25e3b1f6ce82b661605708d0b8292c03f47 (patch)
treeb8c60917145c0a076da1e88dd73edfaad594d5a6 /lxqt-base/lxqt-notificationd
parent3f5a5d10d87cd7f434c3a4207fc0a7ffc25d9123 (diff)
gentoo auto-resync : 09:11:2023 - 22:33:12
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest2
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-1.4.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index 3f2bd010c18a..47faee268dc9 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-notificationd-1.3.0.tar.xz 61064 BLAKE2B 249a2cd764cb8ca0bbd4de1bb903df87b58d1efe6cab775edc60dfd4ac6da7bac4f83fad95d3567df7fd4adb3a0a06372fbd70b44a71a4e40b03dfdd3a062710 SHA512 8bc57c8a6710aaa5d050802a588530ec446611362eaa7c87aae2dae74b7ed9745486a90efbd854dedf79bc9994e13b5444f8b5259452614e01a8b393dd796607
+DIST lxqt-notificationd-1.4.0.tar.xz 61792 BLAKE2B e44c9e80c9fb964547902d242ea0cb5967977e4e9dad1c047daae8dadd105f97fd1cd30c5022511d9ece3c3f1e6fbf74ef79e2a5df2e2725603d3d1151dfb166 SHA512 5ae28b0f49e1e01c8d0fe96f23b961ca962dab33f16025af172777f385d0fd3471c64a7acb78b46e7dc0c370d324a17f10ec9a4c4b3afbde95d47164a5246d0a
EBUILD lxqt-notificationd-1.3.0.ebuild 811 BLAKE2B 30b86a2d9aca48f41b201efcd90c5cff22883dbcf4f957384cb562111bcbdabcd8ec20f6102b855e014a07ec6489b68416045e30f3f24e667e322aac9ce88f92 SHA512 6d30d9e225bc7f651cc0e9f83ae6e0f5c891e3bc784fd5b6e6275500a517381ff00ec0c865af36598df1820c576fe61dcdc46f7576d9336de53207857fbf822a
+EBUILD lxqt-notificationd-1.4.0.ebuild 814 BLAKE2B 1fbddcb8b38c5790879fc38689bef912949e954673a94b846681491f94f6c28bf3b49b4a8a43e9bb096b087a53b8fb51bbcbe3d4f460f0f1ca40f16ad384b3b0 SHA512 6b96635b02f81b718249c4663376354691c7b735b25d9d37d4aaabb832f4b2a3eaacdb026c30c2d29356ca3dae9904df0b066295e2a342d46cc444920408ac1f
MISC metadata.xml 324 BLAKE2B 9a9ade6923097018d9e6caa51617b06c04df45227a4afbf512e04a54e2e5387f162c9b48483ff0f2fa9451a118f8b372bd1d3a487a0be2f3c896524611fe97c6 SHA512 252b5a4a24e16a6cc461670adafccb7041a8229414bd68e564ceadab8bd1ee7141fc43d8db9b6a04c161c947749c28e21815d40f49f44ea049a23167d408368f
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.4.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.4.0.ebuild
new file mode 100644
index 000000000000..4f65c2d4b0d3
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.11.0
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"