summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
commit5a1fb66df455454109e1de61d38b48f509dc68b8 (patch)
tree0213f12db1b0138bffda43d11208c5d701967638 /lxqt-base/lxqt-notificationd
parent3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (diff)
gentoo auto-resync : 18:04:2023 - 05:54:20
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest2
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-1.3.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index 5e158ade5682..74b59cc52ef4 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-notificationd-1.2.0.tar.xz 60720 BLAKE2B 90d2676e4efd3a46bd6e11becf815c9746bf7ae9f8bb5de5ba48df5af433c91a285f048139cf87a3d1857c2c79ff904e75fdb3b085da80b51e196c07e17e488e SHA512 55ae52cf45942ee7992b099cbea1f81776ab7cc17401f903772458dee3e7ea1899bda13c5e6c5e117b2397dbbbe349c6e06dd389f51b03d4853b2f93c5cb000a
+DIST lxqt-notificationd-1.3.0.tar.xz 61064 BLAKE2B 249a2cd764cb8ca0bbd4de1bb903df87b58d1efe6cab775edc60dfd4ac6da7bac4f83fad95d3567df7fd4adb3a0a06372fbd70b44a71a4e40b03dfdd3a062710 SHA512 8bc57c8a6710aaa5d050802a588530ec446611362eaa7c87aae2dae74b7ed9745486a90efbd854dedf79bc9994e13b5444f8b5259452614e01a8b393dd796607
EBUILD lxqt-notificationd-1.2.0.ebuild 811 BLAKE2B 846ad1aa2add50ae4c377723f2b4e2de4b1d496130daef16b4e0041014503712e598bafc28997fe051ef287416d849c117be77bda04a65f3e4f2f06e39ab99c3 SHA512 3a75de40f9dab3a12c41d78cc76b49c1bf15cc4ae78763e952427ef559518602fdfe612210075254ea0a3e7a7fa47b6c176441a165d9e9fa6a58accf7215460d
+EBUILD lxqt-notificationd-1.3.0.ebuild 814 BLAKE2B 1fbddcb8b38c5790879fc38689bef912949e954673a94b846681491f94f6c28bf3b49b4a8a43e9bb096b087a53b8fb51bbcbe3d4f460f0f1ca40f16ad384b3b0 SHA512 6b96635b02f81b718249c4663376354691c7b735b25d9d37d4aaabb832f4b2a3eaacdb026c30c2d29356ca3dae9904df0b066295e2a342d46cc444920408ac1f
MISC metadata.xml 324 BLAKE2B 9a9ade6923097018d9e6caa51617b06c04df45227a4afbf512e04a54e2e5387f162c9b48483ff0f2fa9451a118f8b372bd1d3a487a0be2f3c896524611fe97c6 SHA512 252b5a4a24e16a6cc461670adafccb7041a8229414bd68e564ceadab8bd1ee7141fc43d8db9b6a04c161c947749c28e21815d40f49f44ea049a23167d408368f
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.3.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.3.0.ebuild
new file mode 100644
index 000000000000..4f65c2d4b0d3
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.11.0
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"