summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /lxqt-base/lxqt-notificationd
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest2
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.17.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index 6cea2b620613..2b050e184044 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-notificationd-0.16.0.tar.xz 50696 BLAKE2B e41528091c9c8abfbcd4de53daf753d5f031f9941a83c1e8c0a4f492dba85d1edd08185726dc3f68d0553c5f23a6f97a9835061bdad47abe98c4f0a54ec942f4 SHA512 127f1c044babb0c7a640d862fc9f30947b06ef37b702a75bc72a87f82f9aff15b32e29272993eb9d888e1c8db93e81cec8d07be515c769c560ecce4b439bb2f3
+DIST lxqt-notificationd-0.17.0.tar.xz 53712 BLAKE2B d15f00179eb24c43add51f246b46738d4da6f9ce89f041a65ce4acc252ebd0a832519c0e9e7ac2ee86d23806a2ac6a9a740b57fc5e88d73a09d1170e405386ef SHA512 042d69e01c3015d254ae3472867de0b41587af2285cd26445cd9d6d455de8ef713413431dea9997f2d2e19f70c2c8c73af39ce880d54ecb9fd6c50cd05a7dba4
EBUILD lxqt-notificationd-0.16.0.ebuild 769 BLAKE2B 07a4ed1cd2053733a9ee618e6d1a139df819fdc03c0bb94c0783d07b8dff0c4e4f8ee56cd10bd4d592d4d028146f851b90f2400907bdcde11e913436ce4f7bd9 SHA512 a9c58f7fe7622d807023a90d494b89bf29ff01ada24cc13ee98821747a20dc6ee26dba9b8aca2ad5415b6120610baab33c9079d97a0578bc2a3e221de1519f54
+EBUILD lxqt-notificationd-0.17.0.ebuild 748 BLAKE2B f5ecb77a84e3ac722f9a511e7e06c7a8fd7f68ecd76e604f774733d279646d5316003dfb8bd3f694b7128b5739a4bc3aa4ab467716a9b7d7b661f1fcffe46298 SHA512 0165aa854aaa33b73efbb470cdb700e7e0a670aca9193bb026f170573b04df94e705c61e0d09d50ff9384858f67cdf5529789894c2da912fc4405008ed8d6f4e
MISC metadata.xml 323 BLAKE2B cc28b17d478bed98b59743c03ceb630cc65495414d1dd5703b917643f54ff606518016358e2b0149cc25082097a1e8dd5cb2ee173c235aa6cc4197d9cc258493 SHA512 3aa6fb296384049f738b51edf21ea16a7a68cad1cf5bc79c6c34f970f12292afdb44eb34bf6b48c8e884903dfad041e1078b7409427aaeaabee48d5ee5c1bc14
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.17.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.17.0.ebuild
new file mode 100644
index 000000000000..aa55c540805f
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.17.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}"