summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
commit28e3d252dc8ac8a5635206dfefe1cfe05058d1db (patch)
treee75bce604750fb72e53ed3684059e2e5d2094509 /lxqt-base/lxqt-notificationd
parentf625b9919a60a30f1bd860f7d1b2eac183ced593 (diff)
gentoo resync : 12.08.2018
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest4
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.13.0.ebuild42
-rw-r--r--lxqt-base/lxqt-notificationd/metadata.xml11
3 files changed, 52 insertions, 5 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index 067a3740cfbb..c18442789f69 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-notificationd-0.11.0.tar.xz 30592 BLAKE2B d30ddedf7cc66bc951291110d43c458ff8c4b229189a3d1f3b59be29e0e45ad03ae9839a31aa5dd268121bb6a7266e05d30221ee9cb44a39bbb36cd937c85ebd SHA512 f6dd3463ac993d7c7743addd6924dc8f15717f658c576c78ad01e4db361d1f1c98d02f6a2bec0069c191ad923b1ff63d49faf6ff7d564f67030233d6979adec5
+DIST lxqt-notificationd-0.13.0.tar.xz 32364 BLAKE2B c43e57e66e2fdd375f25afd68acc428c6204992e48c2b2bf1a692380bcb2f48663c52b3a5a9b17d01a68d6cb57e6779260da3c9e09873baa0a8c7489dfa9c9a7 SHA512 2bc75b840a666e013d914f08719680cf3af7430a6acfb5072facff8bdc964aeef1d5227c68b5a5c5d8a6d6c572632105e3f2f04c517d8e8669eb40b5a0cf0f4d
EBUILD lxqt-notificationd-0.11.0.ebuild 844 BLAKE2B 88a320eec4dbede23e76214ffa785cab5b6ed3f0b6fb16233c36393ad7da0f0425fb1fa33bad81d40286c58be16d32399675ca467fb81ac0cc5d3611c3e16020 SHA512 8cf12ce7c1c25a9437a8257d750056d4631093d8c0f7e69dcd06607d265dfad9c47c121a8744fca9a7a85ced84f474eba65798ab1c9240f822c358c4bfba9cca
-MISC metadata.xml 240 BLAKE2B 8dd1dd10c1b3297bf08ebf11d2e047de07700e5233e26788943af60613a3faa71ff392f77a33f0065917eedc487b2f9be91bdc58635c3c51957e5be2738282c0 SHA512 84f77a0e7d17d09eea1157217fcd22ae5fc98e1569879f85b5fc950d2b2ad00168b1ec9d5d8c1f964673c55bc91d509adb2d39b5983de21d83200ef6c58b9652
+EBUILD lxqt-notificationd-0.13.0.ebuild 852 BLAKE2B f5dd0d30255799d945c29fd8c4bb874deff4a9cc8aa815d069208c2eacc1029b23f941dff08767b3a638508b3aaebb17db301edb3bcd1b8a8d89b2e7eb8e2e24 SHA512 558c93cc60cfc716dd86d2fa764c76d57d7b0951b72e4173ca8c13209f3df346daaab0e80295a64ce59ad30591a274a29a9287d8467687e4d7901a3c90e258be
+MISC metadata.xml 323 BLAKE2B cc28b17d478bed98b59743c03ceb630cc65495414d1dd5703b917643f54ff606518016358e2b0149cc25082097a1e8dd5cb2ee173c235aa6cc4197d9cc258493 SHA512 3aa6fb296384049f738b51edf21ea16a7a68cad1cf5bc79c6c34f970f12292afdb44eb34bf6b48c8e884903dfad041e1078b7409427aaeaabee48d5ee5c1bc14
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.13.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.13.0.ebuild
new file mode 100644
index 000000000000..de85f45f010b
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eapi7-ver
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/libqtxdg-3.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ !lxqt-base/lxqt-common
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.5.0
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ )
+ cmake-utils_src_configure
+}
diff --git a/lxqt-base/lxqt-notificationd/metadata.xml b/lxqt-base/lxqt-notificationd/metadata.xml
index a40a83a9c6a9..097def323519 100644
--- a/lxqt-base/lxqt-notificationd/metadata.xml
+++ b/lxqt-base/lxqt-notificationd/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>lxqt@gentoo.org</email>
- <name>LXQt</name>
- </maintainer>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/lxqt-notifcationd</remote-id>
+ </upstream>
</pkgmetadata>