summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-globalkeys
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /lxqt-base/lxqt-globalkeys
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'lxqt-base/lxqt-globalkeys')
-rw-r--r--lxqt-base/lxqt-globalkeys/Manifest2
-rw-r--r--lxqt-base/lxqt-globalkeys/lxqt-globalkeys-1.0.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-globalkeys/Manifest b/lxqt-base/lxqt-globalkeys/Manifest
index 5f9cfacdf47b..3e8baf6a9540 100644
--- a/lxqt-base/lxqt-globalkeys/Manifest
+++ b/lxqt-base/lxqt-globalkeys/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-globalkeys-0.17.0.tar.xz 70584 BLAKE2B af64fca5edb426e073397380115bb06086e354218a14abfad0452f24ac7684d955ed22c977307f45c49d950b148269b92776d5e0b3fb2488836f696bf7505a96 SHA512 1362eec17d96a5352b647db6f55c13cbe1d375b444d1d3d75e3171257ec9b476abfc023e7014c0923b525b5c3b539fde83ac829f2b2256e217e8dc98e6862cb3
+DIST lxqt-globalkeys-1.0.1.tar.xz 73136 BLAKE2B aea0ab34b64ea91fe009b9e5afded28390344c1e1a488d8a14c0443fd202cacbe253e37fb2f8ececd3e51e2c35d01779b2b1cf8163bc289a2c29f882f2b32f76 SHA512 61e12bde1bc0ae3a8c0757673774ba10915791ee06d7a5b08b8de6f869d84efdfe3edc55e5b3a15ede3f6141a90391775cf8d552879e8dc56fe3fb6cf32f2cc6
EBUILD lxqt-globalkeys-0.17.0.ebuild 833 BLAKE2B 205bab534808d8bfbd7de6099e58d7c72e6bbc181604e6fe51d5a1832b0c9a8fd64d30185937ffac9195528e7edd1e1a4a52bb89db1e65cddb3d67d0cbb6c1ee SHA512 4fde63800f58ebd0a15bd54026ed125b0dae05650790d9a6bd507d53349e91ef333e920cae9f8a0f291b484885de05704ba11672426e25aae868de2da017f848
+EBUILD lxqt-globalkeys-1.0.1.ebuild 827 BLAKE2B c2c8351478b658ba11e9bec8f8f672ff76562a585713cea71ea7f6e4ac7bff74c6e36778b0131d9ef8fa9c0accba96168a09d064b8cc1564cf949893b4cf0f82 SHA512 89e5846610c81fe3a22c65110331c97b637f57bf0365ec41b502781edb407f95de7f3f018edf31916287287f79ff7ae3713b06d94ded8b49715611a92b05253e
MISC metadata.xml 322 BLAKE2B 744c3616bee3483129c6169f790e4eb440d5c0b5cbab966ce49bb9de1e2c8685c26036a05a0015aa75fc9cdc840f98a6ceeedb666af416da03adc7b004cc3c37 SHA512 5e42e824230bc18607d3f16c49b2d25dcad4b5e33ec66dc1611c8ce8cf932e1697c040f7331da6975195ba3254299e01975df6c5a925890a92d5b6d43879e8cf
diff --git a/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-1.0.1.ebuild b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-1.0.1.ebuild
new file mode 100644
index 000000000000..b9a3c54ee667
--- /dev/null
+++ b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Daemon and library for global keyboard shortcuts registration"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.9.0
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"