summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-config
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /lxqt-base/lxqt-config
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'lxqt-base/lxqt-config')
-rw-r--r--lxqt-base/lxqt-config/Manifest4
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.14.1.ebuild73
-rw-r--r--lxqt-base/lxqt-config/metadata.xml3
3 files changed, 78 insertions, 2 deletions
diff --git a/lxqt-base/lxqt-config/Manifest b/lxqt-base/lxqt-config/Manifest
index 5aaf86d8b4e6..96ddb788bd5e 100644
--- a/lxqt-base/lxqt-config/Manifest
+++ b/lxqt-base/lxqt-config/Manifest
@@ -1,4 +1,6 @@
AUX lxqt-config-0.13.0-remove-dependency-on-QtConcurrent.patch 1122 BLAKE2B cca7503b2c68300ad1232b7688ceb367801e9454c80d5c2af4a9385d4807b0beedb6ef0b8aa57768d928d420b0d668c22a661971115c93fccf7bb72e4d563407 SHA512 4cdd61471c47e79794054ee58573dd7346e5f88fb869458f8e828d7c1f01af4d73a5d0648b6ad79382bba140ed731c7604f86851f85afa614a1c19cf5a366792
DIST lxqt-config-0.13.0.tar.xz 201112 BLAKE2B 6a79c1f07e1cf055da09bb7dd8f7da2426891770b0e757ba3c4e5ef137f715ba3a579b2c05a4f1938c9d76b6dda0643119888be7dace2083a57a7dfe0df93aa5 SHA512 a5102794c4cf18a18e633cbc7d0b89653abf2612bc61e506ec169f4898903092f5201a09a2610642c641a17b59a992a6d6f59366ec61d54763e8b911d5220ca9
+DIST lxqt-config-0.14.1.tar.xz 293304 BLAKE2B f090d7878815edc4f3f0078301a099ffc8ff57865516a9097db75faa1627af33c60d76b75cef8a7da5e9e790869e6768f54c3b17c59b038578f22d645c3c22fd SHA512 747644f8e0623cb2e8eadda57c7307387423152a089d5b423b06650fbf235371764a26e82363cbee9db5c1145e3fdb754e6ecdcf0930dccec375dda424c8b13f
EBUILD lxqt-config-0.13.0.ebuild 1405 BLAKE2B 0e3701718b5b3812bfda4903ddb47011004cf87862997c6adbb43544b4e8f398177fe9c8661ea61fd85197cceb8e2623047a065767c046274a03d358dda3c433 SHA512 c4032c1a2b7f77769bece058a53b6c0010e744d87192c3f7d01cd4b6b941ccf1889559c372c493255f690ede8629a7c6b90fa90b4fc214fe35a2ff95ec435158
-MISC metadata.xml 435 BLAKE2B f2ac19945e50b82b13706f0fc3790e547243f4a30b2abde7f2b333fd29590dee96d3dc2680380d3db905cc26d93273d36529310c4e68a892163b9a5fc1c87e72 SHA512 2d345ec5a53c4293f632ac65ce0f45f4604914a019f31536de00039dd523f95b23ba830b3c783ef1cfff3f7343e7eb343b4501d001fb3322a50f998394556222
+EBUILD lxqt-config-0.14.1.ebuild 1458 BLAKE2B 9d769e034a53f240f7f8650b32ecf246ae2e5a2dbf4358bb5a43ad76e30c720cf8353f61c372e9430c08c0525108c06f418f7b6d81cf8724d28b54e8915100d0 SHA512 4f5ede5d71397c83a524e9f4d38c1d05f8ec7c2df6339c0eb1e35de9b9372cf18e120d93530eaf7bab5293cde43baba754963cd1f6ef03932833917a97e4a4e6
+MISC metadata.xml 450 BLAKE2B 6f59cf0984e8e6c625eef75e01275d3d9e0b09fdbc1fc82fffb8611b44654da27da256148350c632673352ebc397f07b4696efad6f1f0d35489468752a4293cb SHA512 9e74d2cdc46c1c7797ac91f141995fbab7e11f4f05bef094e2af89d3cfe7d47d209de3de5726eee2eb45926185803ff7c7f012aad994f1acbc43feca88e798fc
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.14.1.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.14.1.ebuild
new file mode 100644
index 000000000000..838fe79c5218
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-0.14.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
+SLOT="0"
+IUSE="+monitor +touchpad"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ sys-libs/zlib:=
+ x11-apps/setxkbmap
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ monitor? ( kde-plasma/libkscreen:5= )
+ touchpad? (
+ virtual/libudev
+ x11-drivers/xf86-input-libinput
+ x11-libs/libXext
+ )
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MONITOR="$(usex monitor)"
+ -DWITH_TOUCHPAD="$(usex touchpad)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/lxqt-base/lxqt-config/metadata.xml b/lxqt-base/lxqt-config/metadata.xml
index d6f2207daed6..f6bf1a5dc530 100644
--- a/lxqt-base/lxqt-config/metadata.xml
+++ b/lxqt-base/lxqt-config/metadata.xml
@@ -9,6 +9,7 @@
<remote-id type="github">lxqt/lxqt-config</remote-id>
</upstream>
<use>
- <flag name="monitor" restrict="&gt;=lxqt-base/lxqt-config-0.13.0">Build monitor settings tool</flag>
+ <flag name="monitor">Build monitor settings tool</flag>
+ <flag name="touchpad">Build touchpad settings tool</flag>
</use>
</pkgmetadata>