summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-admin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /lxqt-base/lxqt-admin
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'lxqt-base/lxqt-admin')
-rw-r--r--lxqt-base/lxqt-admin/Manifest2
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/Manifest b/lxqt-base/lxqt-admin/Manifest
index 37660515be89..ab1342994289 100644
--- a/lxqt-base/lxqt-admin/Manifest
+++ b/lxqt-base/lxqt-admin/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-admin-0.13.0.tar.xz 116436 BLAKE2B 9395ea5f762da37ebb810c167c66c069b15b86b6b71e4a679d6923a0deedd9a87da65469b3ad5c934f9898e91776eee7ec7a248996283201287d00459f69e5c0 SHA512 fc84f2cffd28ea87833194b36654016d426c3b0e7a468468568f35153b208129d504200b31c17516298444882bc54ad7e3bc1cbef2b67459515eaac3dc77dea7
+DIST lxqt-admin-0.14.1.tar.xz 141088 BLAKE2B 89e84167b4dfe67f2c7831a8d2ec4ee8805518d421e36b5cc1ed482e2166c85c54150ff54789f4e0e3f9fd6a5d202f620d2da60f79a0a23178ac0bf9882108df SHA512 bd6272a3042a71e9e00b2ba10be2575649c2d2750a4e00a6e11adaae6b91ccab5e3cf79a8ceb7bfbe808ec80c139b93e02cd96990f80b68a77a974c063e6a373
EBUILD lxqt-admin-0.13.0.ebuild 766 BLAKE2B bb5559376fb6ac970c69dd679f104f1304b568e456e80104cd62915e5f0b22118ddb628175ac94bb399c82f364d5ff6f1e7fac33050518bfbdc0a521c164ad36 SHA512 4d2444ad1f09440467875cd27d46056fff7c781a605e7f7db91472adb95ac6a5f82920eb29f260f3aa09f54c5d43ce0f25d2926e948b7ec78bfe77778b479348
+EBUILD lxqt-admin-0.14.1.ebuild 690 BLAKE2B 3b5d61df20aa97c83b9f860b61aa423c3c52460613b082664d929a3cfe8d0e1dafdccfcb7e222aa4217844b83590cdb72fb968da5e782c7850e3340e732c59f8 SHA512 fa597a6ca19eb004747dab5ba30f8b16d06ecaa01a8c2cbd24d6b2dd6cebdee33c3629a27edec5152eccc9b59725f9a339777315426aee6c59f92d08c09637b1
MISC metadata.xml 316 BLAKE2B be2bd5cb125c608cd60b791dd173079f9a18b247dd7113dd5ff7b9c893b10bb62678e0463553d3f16b10a92a40e88bfe4aa75aca0d5b3ffca9d4024b8e0c43ca SHA512 4fa962d54db76373af467ffcead4c651b8fc226e8da994c6b574dff81e5e1013ff5609c19bcfdeba669809e42c0141cb135248fd48f151781dd611703c88035e
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild
new file mode 100644
index 000000000000..af58883a5fdd
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-0.14.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.6.0"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ kde-frameworks/kwindowsystem:5
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"