summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-admin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /lxqt-base/lxqt-admin
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'lxqt-base/lxqt-admin')
-rw-r--r--lxqt-base/lxqt-admin/Manifest2
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-0.17.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/Manifest b/lxqt-base/lxqt-admin/Manifest
index 39d5b7a0cefb..b8c703b4eeba 100644
--- a/lxqt-base/lxqt-admin/Manifest
+++ b/lxqt-base/lxqt-admin/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-admin-0.16.0.tar.xz 143724 BLAKE2B 8a9c13ea52fefe813d6fecc45e2b9263da34fa7ec5b3c28054ab8b728d813782ff351d328fed36e7c2a8bd55cde05633d4b937edbbadebd1daf25472d47da289 SHA512 ed61e886a52985f67c38d39d949fabbd5532ebf61f232d4d2accf144b8fc650f85457e0e8b6066fad3f914ad61f8b1779360c886d3622c09765e421dfcea2484
+DIST lxqt-admin-0.17.0.tar.xz 145620 BLAKE2B 3f1bc0870ef33a85a14dca559951826c56a2ebe81f6cad53917db87ce38b909aed4daed7964d202715dd4d9c7947b23f2aba0fdcb020b6b418c91d9f12c90573 SHA512 5d807b1bbde586130ab03cecf43dc190cbbed5c16842d14779f67f7b514689e7ea330f6c75916c733e4e840242d7feaceb4b6e0932ece1ca70bff208eb5e8072
EBUILD lxqt-admin-0.16.0.ebuild 693 BLAKE2B e991e6cdb756cb5905bbc983eb3d4a124104eeacf6097bd3aeff20a88fc79c3d1b5b1e014186b40c141060f56716ce90402ce99802f9747784db61bd046d5012 SHA512 15066b81f4e33208917c6f2ca1abdfb471297a22d6ee834d8226a21ecb3b27524f2e842e2f60169fe87cc84525087a6615d57fc38c065a90080328415f7bac3f
+EBUILD lxqt-admin-0.17.0.ebuild 702 BLAKE2B 53adedfd675097c807be9b7e12adce34794e7fb75d0c35e90d0a2583e2c2eed09addf3d53821e3044be82a4499682b9094717a8dd07547d964cc87a4911f4c33 SHA512 e009e4631bdb1b6d2e3cfafba5293d6a6d519575b731d252fb102add8d92613656b78fa429dfb1f3191d421af3a50738cdbf921e7b250894bdd6cfd473fdf864
MISC metadata.xml 316 BLAKE2B be2bd5cb125c608cd60b791dd173079f9a18b247dd7113dd5ff7b9c893b10bb62678e0463553d3f16b10a92a40e88bfe4aa75aca0d5b3ffca9d4024b8e0c43ca SHA512 4fa962d54db76373af467ffcead4c651b8fc226e8da994c6b574dff81e5e1013ff5609c19bcfdeba669809e42c0141cb135248fd48f151781dd611703c88035e
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-0.17.0.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-0.17.0.ebuild
new file mode 100644
index 000000000000..bfe05e04e78e
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-0.17.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.9.0"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ kde-frameworks/kwindowsystem:5
+ >=sys-auth/polkit-qt-0.113.0
+"
+RDEPEND="${DEPEND}"