summaryrefslogtreecommitdiff
path: root/lxqt-base/libsysstat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /lxqt-base/libsysstat
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'lxqt-base/libsysstat')
-rw-r--r--lxqt-base/libsysstat/Manifest2
-rw-r--r--lxqt-base/libsysstat/libsysstat-0.4.5.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/lxqt-base/libsysstat/Manifest b/lxqt-base/libsysstat/Manifest
index 4a1f178dc110..420b584815c8 100644
--- a/lxqt-base/libsysstat/Manifest
+++ b/lxqt-base/libsysstat/Manifest
@@ -1,3 +1,5 @@
DIST libsysstat-0.4.4.tar.xz 17532 BLAKE2B d2f58ef95ef1bd139d174f2edcdebb3847df45c712c27f2bec5e0afdf4cf4c9b49a3996d8d28e27212b4d6866f505b87a58b0c72e8c4f31ad1c5a3632e8b130c SHA512 2d3545f6b3872dd48f9d4537352e6f8884cf10adca71625f75da7898a71c3100df996b6a3f8cd851d352347db5b82c67402172831179c574639c75dd35ed1d88
+DIST libsysstat-0.4.5.tar.xz 17744 BLAKE2B 5739b57960b1169be3a16fe77aeaf5c43542d545a3a3195f4f3c4d9514d575744c95231052abe7d8afd0adffd0a0465bc7f4e338022664018e179b03480d4158 SHA512 1b9091b783e32aeb258bef0e7ea070456f577a42fc5052ebf215dccb195f51c34ae7c2e6178e4eaf12200c5155c53699c2dbfe2a1f7c0c35d06c04275455ed09
EBUILD libsysstat-0.4.4.ebuild 550 BLAKE2B cd069da3427bfdd40be5905c83eb1e95cba60ed55e0c81aa82daf57cc6f856b1a56d4e3f84518494de96722fce58f950521796e6f0a14372534211c94efc4d05 SHA512 7ccdaff786432b3049984b67d8af48fb93c0a3eb952fd199c350942dd148da5ffe45fa31940474ef288a47a544001552973faa12edad60136678989a5b7a88fe
+EBUILD libsysstat-0.4.5.ebuild 552 BLAKE2B 501b4e52da4ad1b6b0dfa233447000689ff347c8186942ae8491930ae972815a1f183bc95d567c5999b1e5135cd5556f85ec036e50b8acd65b52c5ffa8e85c38 SHA512 186672bd7b8594b0c9cc150b3003c49b19f33c5544d04995ba4f35b909f3a802340ac61bcc9222a8b888d64b1e18e3bb41d2ec9b8fab7527f382c911ad516290
MISC metadata.xml 316 BLAKE2B dc4c870d7a406c938756a0a5df097283f0d001d10b7bc9a2beb1730214405578f97faf60d9475fe7ba93b649ed33e8b1dd4bf40eec4091e405fc1eecf8b9e450 SHA512 3f9226fbc9629f0c61468c7bc142904fc2e4087a425d528def9f6432c31f3aead2f77959d49337aa3431975306e8ce3ee1d7d8e5d13ce57d20a62538fc7f4ce4
diff --git a/lxqt-base/libsysstat/libsysstat-0.4.5.ebuild b/lxqt-base/libsysstat/libsysstat-0.4.5.ebuild
new file mode 100644
index 000000000000..8ef502bd5594
--- /dev/null
+++ b/lxqt-base/libsysstat/libsysstat-0.4.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt GUI for System Statistics"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.9.0"
+DEPEND="dev-qt/qtcore:5"
+RDEPEND="${DEPEND}"