summaryrefslogtreecommitdiff
path: root/kde-plasma/wacomtablet/wacomtablet-6.0.90.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-29 00:07:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-29 00:07:15 +0100
commit5c4786a868bad6e3f46aecf32ad6c6dc5de98408 (patch)
tree1a1792815761a5b6f645c8d55b6b698e102dca48 /kde-plasma/wacomtablet/wacomtablet-6.0.90.ebuild
parent3c1648a0749c1d66b300d857e6b417c1162890da (diff)
gentoo auto-resync : 29:05:2024 - 00:07:15
Diffstat (limited to 'kde-plasma/wacomtablet/wacomtablet-6.0.90.ebuild')
-rw-r--r--kde-plasma/wacomtablet/wacomtablet-6.0.90.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/kde-plasma/wacomtablet/wacomtablet-6.0.90.ebuild b/kde-plasma/wacomtablet/wacomtablet-6.0.90.ebuild
new file mode 100644
index 000000000000..2c73758084e9
--- /dev/null
+++ b/kde-plasma/wacomtablet/wacomtablet-6.0.90.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=6.2.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.7.1
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Wacom system settings module that supports different button/pen layout profiles"
+HOMEPAGE="https://userbase.kde.org/Wacomtablet"
+
+LICENSE="GPL-2"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# slot op: Uses Qt6::GuiPrivate for qtx11extras_p.h
+RDEPEND="
+ >=dev-libs/libwacom-0.30:=
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kglobalaccel-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-plasma/libplasma-${PVCUT}:6
+ >=kde-plasma/plasma5support-${PVCUT}:6
+ >=x11-drivers/xf86-input-wacom-0.20.0
+ x11-libs/libXi
+ x11-libs/libxcb
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libX11
+"
+BDEPEND="sys-devel/gettext"
+
+src_test() {
+ # test needs DBus, bug 675548
+ local myctestargs=(
+ -E "(Test.KDED.DBusTabletService)"
+ )
+
+ ecm_src_test
+}