summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-workspace/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-plasma/plasma-workspace/files
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-plasma/plasma-workspace/files')
-rw-r--r--kde-plasma/plasma-workspace/files/10-agent-shutdown.sh17
-rw-r--r--kde-plasma/plasma-workspace/files/10-agent-startup.sh58
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.10-startplasmacompositor-script.patch40
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.10.4-unused-dep.patch19
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.10.5-devicenotifier.patch32
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.4-startkde-script.patch40
6 files changed, 206 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/10-agent-shutdown.sh b/kde-plasma/plasma-workspace/files/10-agent-shutdown.sh
new file mode 100644
index 000000000000..4bafd2e61cf4
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/10-agent-shutdown.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# This file is executed at Plasma shutdown.
+# Uncomment the following lines to kill the agents
+# that were started at session startup.
+
+# gnupg 2.0.x
+#if [ -n "${GPG_AGENT_INFO}" ]; then
+# kill $(echo ${GPG_AGENT_INFO} | cut -d':' -f 2) >/dev/null 2>&1
+#fi
+
+# gnupg 2.1.x
+#gpgconf --kill gpg-agent >/dev/null 2>&1
+
+#if [ -n "${SSH_AGENT_PID}" ]; then
+# eval "$(ssh-agent -s -k)"
+#fi
diff --git a/kde-plasma/plasma-workspace/files/10-agent-startup.sh b/kde-plasma/plasma-workspace/files/10-agent-startup.sh
new file mode 100644
index 000000000000..fc5ba70539d9
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/10-agent-startup.sh
@@ -0,0 +1,58 @@
+# Agents startup file
+#
+# This file is sourced at Plasma startup, so that
+# the environment variables set here are available
+# throughout the session.
+#
+# Uncomment the following lines to start gpg-agent
+# and/or ssh-agent at Plasma startup.
+# If you do so, do not forget to uncomment the respective
+# lines in PLASMADIR/shutdown/agent-shutdown.sh to
+# properly kill the agents when the session ends.
+#
+# If using gpg-agent for ssh instead of ssh-agent, a GUI pinentry program
+# must be selected either with eselect pinentry or adding an entry to
+# $HOME/.gnupg/gpg-agent.conf such as "pinentry-program /usr/bin/pinentry-qt4".
+#
+# If using gnupg-2.1 or later with gpg-agent for ssh instead of ssh-agent,
+# $HOME/.gnupg/gpg-agent.conf must be edited to include "enable-ssh-support".
+# See bug #547544 for details of why.
+#
+# pinentry-curses or pinentry-tty will not work because the agent started here
+# is in a different tty than where it is used, so the agent does not know where
+# to request the passphrase and fails.
+
+#GPG_AGENT=true
+#SSH_AGENT=true
+#SSH_AGENT=gpg # use gpg-agent for ssh instead of ssh-agent
+
+if [ "${GPG_AGENT}" = true ]; then
+ if [ -x /usr/bin/gpgconf ]; then
+ gpgconf --launch gpg-agent >/dev/null 2>&1
+ if [ $? = 2 ]; then
+ eval "$(/usr/bin/gpg-agent --enable-ssh-support --daemon)"
+ fi
+ fi
+fi
+
+if [ "${SSH_AGENT}" = true ]; then
+ if [ -x /usr/bin/ssh-agent ]; then
+ eval "$(/usr/bin/ssh-agent -s)"
+ fi
+elif [ "${SSH_AGENT}" = gpg ] && [ "${GPG_AGENT}" = true ]; then
+ if [ -e /run/user/$(id -ru)/gnupg/S.gpg-agent.ssh ]; then
+ export SSH_AUTH_SOCK=/run/user/$(id -ru)/gnupg/S.gpg-agent.ssh
+ elif [ -e "${HOME}/.gnupg/S.gpg-agent.ssh" ]; then
+ export SSH_AUTH_SOCK=${HOME}/.gnupg/S.gpg-agent.ssh
+ fi
+fi
+
+# Uncomment the following lines to start rxvt-unicode which has the ability to
+# run multiple terminals in one single process, thus starting up faster and
+# saving resources.
+# The --opendisplay ensures that the daemon quits when the X server terminates,
+# therefore we don't need matching lines in agent-shutdown.sh.
+
+#if [ -x /usr/bin/urxvtd ]; then
+# /usr/bin/urxvtd --opendisplay --fork --quiet
+#fi
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.10-startplasmacompositor-script.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.10-startplasmacompositor-script.patch
new file mode 100644
index 000000000000..de56ffe236c7
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.10-startplasmacompositor-script.patch
@@ -0,0 +1,40 @@
+From a9b685f0dab7f21dfa3ed55011c035bab1c972d9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jos=C3=A9=20Pekkarinen?= <koalinux@gmail.com>
+Date: Tue, 1 Aug 2017 23:09:24 +0300
+Subject: [PATCH] Source files in /etc/plasma/{startup,shutdown}
+
+---
+ startkde/startplasmacompositor.cmake | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/startkde/startplasmacompositor.cmake b/startkde/startplasmacompositor.cmake
+index 5bcf26a..e965f19 100644
+--- a/startkde/startplasmacompositor.cmake
++++ b/startkde/startplasmacompositor.cmake
+@@ -157,6 +157,11 @@ for prefix in `echo $scriptpath`; do
+ done
+ done
+
++# Gentoo part for FHS installs
++for file in "@GENTOO_PORTAGE_EPREFIX@/etc/plasma/startup/"*.sh; do
++ test -r "${file}" && . "${file}"
++done
++
+ echo 'startplasmacompositor: Starting up...' 1>&2
+
+ # Make sure that the KDE prefix is first in XDG_DATA_DIRS and that it's set at all.
+@@ -232,6 +237,11 @@ fi
+
+ echo 'startplasmacompositor: Shutting down...' 1>&2
+
++# Gentoo part for FHS installs
++for file in "@GENTOO_PORTAGE_EPREFIX@/etc/plasma/shutdown/"*.sh; do
++ test -r "${file}" && . "${file}"
++done
++
+ unset KDE_FULL_SESSION
+ xprop -root -remove KDE_FULL_SESSION
+ unset KDE_SESSION_VERSION
+--
+2.13.0
+
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.10.4-unused-dep.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.10.4-unused-dep.patch
new file mode 100644
index 000000000000..fa0f38509652
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.10.4-unused-dep.patch
@@ -0,0 +1,19 @@
+commit 5a7d251cfbed417a2617945a94427a93cdd2e82d
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu Jul 27 17:50:17 2017 +0200
+
+ Drop unused dependency
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ba61d1cc..ab5536ff 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,7 +25,7 @@ include(ECMQtDeclareLoggingCategory)
+ include(KDEPackageAppTemplates)
+
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+- Plasma DocTools Runner JsEmbed NotifyConfig Su NewStuff Wallet KCMUtils
++ Plasma DocTools Runner JsEmbed NotifyConfig Su NewStuff Wallet
+ IdleTime Declarative TextWidgets KDELibs4Support Crash GlobalAccel
+ DBusAddons Wayland)
+ find_package(KF5NetworkManagerQt ${KF5_MIN_VERSION})
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.10.5-devicenotifier.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.10.5-devicenotifier.patch
new file mode 100644
index 000000000000..978f326e620f
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.10.5-devicenotifier.patch
@@ -0,0 +1,32 @@
+From b8f263cd9939530a6634a1ddb9533bf473a67805 Mon Sep 17 00:00:00 2001
+From: Kai Uwe Broulik <kde@privat.broulik.de>
+Date: Wed, 23 Aug 2017 11:10:34 +0200
+Subject: [Device Notifier] Set preferred size for ActionItem
+
+In QtQuick Layouts implicit size (set by IconItem to the SVG's natural size) takes
+precedence over width/height. This was fixed in DeviceItem but forgotten here.
+
+BUG: 382541
+FIXED-IN: 5.8.8
+---
+ applets/devicenotifier/package/contents/ui/ActionItem.qml | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/applets/devicenotifier/package/contents/ui/ActionItem.qml b/applets/devicenotifier/package/contents/ui/ActionItem.qml
+index 5e54866..df28365 100644
+--- a/applets/devicenotifier/package/contents/ui/ActionItem.qml
++++ b/applets/devicenotifier/package/contents/ui/ActionItem.qml
+@@ -56,8 +56,8 @@ MouseArea {
+
+ PlasmaCore.IconItem {
+ source: area.icon
+- width: units.iconSizes.smallMedium
+- height: width
++ Layout.preferredWidth: units.iconSizes.smallMedium
++ Layout.preferredHeight: width
+ }
+
+ PlasmaComponents.Label {
+--
+cgit v0.11.2
+
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.4-startkde-script.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.4-startkde-script.patch
new file mode 100644
index 000000000000..1630080ca2c7
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.4-startkde-script.patch
@@ -0,0 +1,40 @@
+From bf569560bf195ac4e79d65d4103a7161a6a2f2ac Mon Sep 17 00:00:00 2001
+From: Elias Probst <mail@eliasprobst.eu>
+Date: Sat, 4 Jul 2015 11:33:01 +0200
+Subject: [PATCH] [startkde] Gentoo FHS script support
+
+---
+ startkde/startkde.cmake | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/startkde/startkde.cmake b/startkde/startkde.cmake
+index 2585600..9350158 100644
+--- a/startkde/startkde.cmake
++++ b/startkde/startkde.cmake
+@@ -210,6 +210,11 @@ for prefix in `echo $scriptpath`; do
+ done
+ done
+
++# Gentoo part for FHS installs
++for file in "@GENTOO_PORTAGE_EPREFIX@/etc/plasma/startup/"*.sh; do
++ test -r "${file}" && . "${file}"
++done
++
+ # Activate the kde font directories.
+ #
+ # There are 4 directories that may be used for supplying fonts for KDE.
+@@ -417,6 +422,11 @@ for prefix in `echo "$scriptpath"`; do
+ done
+ done
+
++# Gentoo part for FHS installs
++for file in "@GENTOO_PORTAGE_EPREFIX@/etc/plasma/shutdown/"*.sh; do
++ test -r "${file}" && . "${file}"
++done
++
+ unset KDE_FULL_SESSION
+ xprop -root -remove KDE_FULL_SESSION
+ unset KDE_SESSION_VERSION
+--
+2.3.6
+