summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-meta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /kde-plasma/plasma-meta
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'kde-plasma/plasma-meta')
-rw-r--r--kde-plasma/plasma-meta/Manifest3
-rw-r--r--kde-plasma/plasma-meta/metadata.xml1
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-5.13.2.ebuild77
3 files changed, 80 insertions, 1 deletions
diff --git a/kde-plasma/plasma-meta/Manifest b/kde-plasma/plasma-meta/Manifest
index 1b037ac528a0..710126095006 100644
--- a/kde-plasma/plasma-meta/Manifest
+++ b/kde-plasma/plasma-meta/Manifest
@@ -1,3 +1,4 @@
EBUILD plasma-meta-5.12.5.ebuild 2139 BLAKE2B 6361bc64d16cd1d3971c72a8943e0ff2530da112809d6f2cfe9e558e51083ab55b4abaf4f6fb0a637b62b30f5d5be03243e77a383edea2edc843256f8dcd7c62 SHA512 c73d0a40a44b16a7bde0277ec019ffdcde5a649cf2b1c5ba9bb3bf12a897137f7993cd205b30f21e8fdf484fefbd1196fee67a35ab8e92aad21bf12e228c2694
EBUILD plasma-meta-5.12.6.ebuild 2141 BLAKE2B 77e2d03c8d7b4340ec792cb2c5ffbc56e31b7ccb5ad32fc64430be4084e854ed5a7000be52e798b2981a9629e9854d3bee11716b514cd8041a92306972affa37 SHA512 c89023a7bc618edc734fc0e60bdac42f14daca2d77cb9a34f875ec815f8b1368ef9905a7929209ef54fb8d393e4c67ef02564149fa5a216bc0ecef49f093e674
-MISC metadata.xml 1199 BLAKE2B a5c21c8b9bedcf1ff127c79779ce8cc0b8afd6c88d4ad71890a621400abad2896b55c11942373cafb16347b8afe572c67ada4e33cdc553ac4efb8f126f5ca5e9 SHA512 de4cf365354410f2ecc83ed1cd3f8adf35e08ecb54fba4eb267b31dfbebe43b893c28642ab7760b66bc3de1cf06990850db799f03e15ea5cc86c902be4e5dfd2
+EBUILD plasma-meta-5.13.2.ebuild 2233 BLAKE2B 77b371fbe460a3dd2ac0db7bf04c7650ffa1fef910f57aaaa87441dd3ca7ea8e803eeffa8c4f24173d752d906659bb2fd7fbc84bb0c22e1003e57e10d1223cd7 SHA512 fa082c43246d02e6da6dfb12dea0c72c68c8757f5d7b2075b7b2858c05f4566ce94cb51f7f885d1fe2d808918b89c297265c6252531b3527d07740371d7cf19e
+MISC metadata.xml 1304 BLAKE2B 09af233977178dbd8bc6943d87db1b5523e3f94d9f7db522d56788e21de9d7d0a9f9fb9bc38331623619524021cf961b35d033cbb5b3155c365154db6df1642d SHA512 f891053e1f87c4daab4024cdd3631e778c2a1c0d5f39b40aefb9ddb263b7d8cd3ec9adaae416562717837a789fbb76baccfd05b1ef11b491a4782926f66a35e4
diff --git a/kde-plasma/plasma-meta/metadata.xml b/kde-plasma/plasma-meta/metadata.xml
index cdf1585f9f20..08b59513fc93 100644
--- a/kde-plasma/plasma-meta/metadata.xml
+++ b/kde-plasma/plasma-meta/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo KDE Project</name>
</maintainer>
<use>
+ <flag name="browser-integration">Enable integration with Chrome/Firefox with browser extensions</flag>
<flag name="crypt">Pull in <pkg>kde-plasma/plasma-vault</pkg> for encrypted vaults integration</flag>
<flag name="display-manager">Pull in a graphical display manager</flag>
<flag name="grub">Pull in Breeze theme for <pkg>sys-boot/grub</pkg></flag>
diff --git a/kde-plasma/plasma-meta/plasma-meta-5.13.2.ebuild b/kde-plasma/plasma-meta/plasma-meta-5.13.2.ebuild
new file mode 100644
index 000000000000..0d1ecf9e0e14
--- /dev/null
+++ b/kde-plasma/plasma-meta/plasma-meta-5.13.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5-functions
+
+DESCRIPTION="Merge this to pull in all Plasma 5 packages"
+HOMEPAGE="https://www.kde.org/workspaces/plasmadesktop/"
+
+LICENSE="metapackage"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bluetooth +browser-integration crypt +display-manager grub gtk +handbook
+legacy-systray networkmanager pam plymouth pulseaudio +sddm sdk +wallpapers"
+
+RDEPEND="
+ $(add_plasma_dep breeze)
+ $(add_plasma_dep drkonqi)
+ $(add_plasma_dep kactivitymanagerd)
+ $(add_plasma_dep kde-cli-tools)
+ $(add_plasma_dep kdecoration)
+ $(add_plasma_dep kdeplasma-addons)
+ $(add_plasma_dep kgamma)
+ $(add_plasma_dep khotkeys)
+ $(add_plasma_dep kinfocenter)
+ $(add_plasma_dep kmenuedit)
+ $(add_plasma_dep kscreen)
+ $(add_plasma_dep kscreenlocker)
+ $(add_plasma_dep ksshaskpass)
+ $(add_plasma_dep ksysguard)
+ $(add_plasma_dep kwayland-integration)
+ $(add_plasma_dep kwin)
+ $(add_plasma_dep kwrited)
+ $(add_plasma_dep libkscreen)
+ $(add_plasma_dep libksysguard)
+ $(add_plasma_dep milou)
+ $(add_plasma_dep oxygen)
+ $(add_plasma_dep plasma-desktop)
+ $(add_plasma_dep plasma-integration)
+ $(add_plasma_dep plasma-workspace)
+ $(add_plasma_dep polkit-kde-agent)
+ $(add_plasma_dep powerdevil)
+ $(add_plasma_dep systemsettings)
+ $(add_plasma_dep user-manager)
+ bluetooth? ( $(add_plasma_dep bluedevil) )
+ browser-integration? ( $(add_plasma_dep plasma-browser-integration) )
+ crypt? ( $(add_plasma_dep plasma-vault) )
+ display-manager? (
+ sddm? (
+ $(add_plasma_dep sddm-kcm)
+ x11-misc/sddm
+ )
+ !sddm? ( x11-misc/lightdm )
+ )
+ grub? ( $(add_plasma_dep breeze-grub) )
+ gtk? (
+ $(add_plasma_dep breeze-gtk)
+ $(add_plasma_dep kde-gtk-config)
+ legacy-systray? (
+ dev-libs/libappindicator:3
+ dev-libs/libappindicator:2
+ )
+ )
+ handbook? ( $(add_kdeapps_dep khelpcenter) )
+ networkmanager? ( $(add_plasma_dep plasma-nm) )
+ pam? ( $(add_plasma_dep kwallet-pam) )
+ plymouth? (
+ $(add_plasma_dep breeze-plymouth)
+ $(add_plasma_dep plymouth-kcm)
+ )
+ pulseaudio? ( $(add_plasma_dep plasma-pa) )
+ sdk? ( $(add_plasma_dep plasma-sdk) )
+ wallpapers? ( $(add_plasma_dep plasma-workspace-wallpapers) )
+"
+
+REQUIRED_USE="legacy-systray? ( gtk )"