summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-meta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
commit5e41a38157bb40e8513e8e34426e85faba672fe7 (patch)
tree38e9365afd56c161d0e970ddf5420b2585130587 /kde-plasma/plasma-meta
parent0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (diff)
gentoo auto-resync : 14:06:2024 - 00:09:04
Diffstat (limited to 'kde-plasma/plasma-meta')
-rw-r--r--kde-plasma/plasma-meta/Manifest2
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild13
2 files changed, 14 insertions, 1 deletions
diff --git a/kde-plasma/plasma-meta/Manifest b/kde-plasma/plasma-meta/Manifest
index 5cee59a0ee7d..212e97e8a974 100644
--- a/kde-plasma/plasma-meta/Manifest
+++ b/kde-plasma/plasma-meta/Manifest
@@ -1,3 +1,3 @@
EBUILD plasma-meta-5.27.11-r1.ebuild 4212 BLAKE2B c1db8c8defe4a168fa0b195635907ba3b6e257db3fe2d4cb82e4808ff1dacb28428b41a36812c8dc0579decef2ca0e499f8ef3fec17e14b802988248e005f3e4 SHA512 79e1eca7478ca7d873e9d16532f8b602b9accad10360922bcf09846f388e21df702254ccafb9e0c42a2f662dedc4177f01602bd6e4889a2a6a555edb28c1e735
-EBUILD plasma-meta-6.0.90-r1.ebuild 4707 BLAKE2B 1c319a44416062601459fbfed2552b57bf51453dc7a484b67d7e9711f1fd0efc4cfedac562dce1283ad09112ae5b69fd8d9f9f3da8d20b620a99c4f797b46785 SHA512 a188ad44af90b04050a8fb8c7016e33fc6b3203b894e58ebf340018f16f3d40cf5bd3735f1847c7b9539e1b9c879b517619cdbcc524cc7e12d1ac4a38e9c9fe4
+EBUILD plasma-meta-6.0.90-r1.ebuild 5255 BLAKE2B 52533730a35df32c0529a2f350b4c6c137d3dc1d3ea231e25aa19ff1e50bb50160bfc543e14197cb4425fee83c425ad9afba987633fca23aa27248532191ebeb SHA512 884130308313d1ba7497ebdc0e9d7f4600024611359eed817408414a1adcb97c0e5ca7d5c74b51a5f8966b35c9920791f29e23ac4171c6754dfd0126b21858d6
MISC metadata.xml 3059 BLAKE2B d3e3485ebb608a603d13f0263533dd97d04ed0f9e9610ee429808f521770a92e59f9fea4992c8d280139cfbe5468029af073813d8195745c7182ae56a95e5d2a SHA512 0576008409be1377c1ac443aad3d039a525e62aba4b7fc93230869a0054640abea0ba40ea69aa3013a8ec7ad48e0c35ba312468626fee5662b41ccaaf86ceb63
diff --git a/kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild b/kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild
index 65f6cd6ca2c5..c7d62908795b 100644
--- a/kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild
+++ b/kde-plasma/plasma-meta/plasma-meta-6.0.90-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit toolchain-funcs
+
DESCRIPTION="Merge this to pull in all Plasma 6 packages"
HOMEPAGE="https://kde.org/plasma-desktop/"
@@ -118,6 +120,17 @@ RDEPEND="${RDEPEND}
"
pkg_postinst() {
+ if [[ $(tc-get-cxx-stdlib) == "libc++" ]] ; then
+ # Workaround for bug #923292 (KDE-bug 479679)
+ ewarn "plasmashell and other KDE Plasma components are known to misbehave"
+ ewarn "when built with sys-libs/libcxx, e.g. crashing when right-clicking"
+ ewarn "on a panel. See bug #923292."
+ ewarn ""
+ ewarn "A possible (no warranty!) workaround is building sys-libs/libcxx and"
+ ewarn "sys-libs/libcxxabi with the following in package.env:"
+ ewarn " MYCMAKEARGS=\"-DLIBCXX_TYPEINFO_COMPARISON_IMPLEMENTATION=1\""
+ fi
+
if ! use qt5 && has_version dev-qt/qtgui; then
ewarn "KF5- and Qt5-based applications will exhibit various integration bugs"
ewarn "and generally look out of place in Plasma 6 without the dependencies"