summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /kde-plasma/plasma-integration
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest2
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.12.6.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index f00b81f1246c..bd873bf178c0 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,5 @@
DIST plasma-integration-5.12.5.tar.xz 53664 BLAKE2B e37d44a0a33116ab1b2b1f1edb74a8616ba33aa41438b93f9bf2f45abe5bb49cda57a579b35b8af94a171074387178888f5b80909e50e9c2be4a7a11a1eb0198 SHA512 5ae667a11ea85c6e9f353939bc22d84c36cbb53f053244a93e7c1d185d20452a7fc3d2afed65427ef938910fa537648006c2dda77346419a6a4492a2e292c787
+DIST plasma-integration-5.12.6.tar.xz 53412 BLAKE2B 3acee7e76786ab570f5c001589137f85decf42bd6857c21a2448269d4735309dcdb7d1f5233ed8c95de4ff5c783a07950f9627525966ba33a47c889da658ddec SHA512 df231e8041fb94f01b0950890f784d118ca0aa1a34e7e483f78351de237cc2ba46a05be9c7addc5a2c5d319be7e17b6e2c5f171da28aa7cfd9b34b585a3c8155
EBUILD plasma-integration-5.12.5.ebuild 1062 BLAKE2B 85677c190ba956334daaf097c03844c989a2897cc089b6eab540c346885cd3f895a906b3a42b555093fd83978ad61abdf6913808f4523f745bab4e346d6a763f SHA512 d0c91184d4d21d945e16881f879a80d689281632f4c1c0822fcc3153d02be427198dc6f7e12af76ddd0d26f362f1caef714f21a41685e6bb604534b58b8053a5
+EBUILD plasma-integration-5.12.6.ebuild 1064 BLAKE2B 85c18e1cd9d36aa41e3067524e11b87fd4fff69c6202a436a80660824b3839d34fac188cea374c64e4edcb3df04564986692f84c71247ef5838b93287956551c SHA512 f4fa6d0cb0b11d269643af29ce695b48859adde40ecb56b7ec299b36df4af341da6d3587242a59fbbcd91e162aed2ef23c5d49896a0db7ea96db8dfb26c622b4
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.12.6.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.12.6.ebuild
new file mode 100644
index 000000000000..1d60d9295f03
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.12.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"