summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-plasma/plasma-integration
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest4
-rw-r--r--kde-plasma/plasma-integration/metadata.xml8
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.10.5.ebuild42
3 files changed, 54 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
new file mode 100644
index 000000000000..f7f666702be8
--- /dev/null
+++ b/kde-plasma/plasma-integration/Manifest
@@ -0,0 +1,4 @@
+DIST plasma-integration-5.10.5.tar.xz 51704 SHA256 56c2adf52399536278dbad3605c1088e214ef6c57c72e06f297da2739be69d95 SHA512 18fbd5c6374ad65119a3df0bb93caa38cc0b4e599be4b20aaf625b7ad1c27a1bcab5efba8dfc7932f0fd64a0ae039251b02dfb0228382a49ed685dd1e8cff900 WHIRLPOOL e272c5e57b4b1af2968b466b34c95abf57bb41e6612c56e3684c64f7fec95da61cec47c773afebc1456a9ff98d8a53a2ca87ddef18c07501dd461cce32630c3c
+EBUILD plasma-integration-5.10.5.ebuild 1030 SHA256 62b2f9e3f0bb293d76201986991dc6878760f9bcb499fea114b7514da2dc9801 SHA512 bd75419ba6dcfaa93b7d386363a95f000da73296fa45085d5800a245bcd700116115205658f35fcc29ba1f769990f4891417c2363a57d2a8a91932da5ed021cb WHIRLPOOL 3c51e40423cd7b1f000a892d7bd38f8d8841db912115384e1129fa0edcee78443dbdd3f8d969cd00cdab5cabacd671f1adba6e1f05d952a2cbd95bb6daa7c796
+MISC ChangeLog 6375 SHA256 2cdaf8bb610421d940996b272346d33df528048495306cf25628cf5f874ecf26 SHA512 f2bbe24e59e13959ede0a4e5d80fb38dc2cb2ef680c876b5a3771c916a57935e10bf301e6772be6461286b80ae64ed43dd57788d7b4c08cf704fa49e6247ed88 WHIRLPOOL a83d08a760e2f2d6c87e13a82b686406362ddf048508f604a362527ca2ffedc184456e444f55f3802b3dcd1d280f8e7fd98c5a5f7ab3da56c9eb78f56f34f996
+MISC metadata.xml 249 SHA256 584f1dcf51866dc24a9abf7a89bfba0fad11dde81ae1c1b715da41770d233c99 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3 WHIRLPOOL 200c07a8bf7c55b11b7936d5cd30e991a511684913334e72f59def66c0ced5fed0b4a8754e2d98bffbab631cb90d4e17fcccc59d5dcc5a8e988f69e47c85518c
diff --git a/kde-plasma/plasma-integration/metadata.xml b/kde-plasma/plasma-integration/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/kde-plasma/plasma-integration/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.10.5.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.10.5.ebuild
new file mode 100644
index 000000000000..7aaf53fa5333
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.10.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"