summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration/plasma-integration-5.27.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-04 23:23:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-04 23:23:41 +0100
commit3b4ca161c9d7f5a66a93191da2c9ec02dbdde1b7 (patch)
tree05ee189fbf7a80ad6a8a565742051527322cbbdd /kde-plasma/plasma-integration/plasma-integration-5.27.4.ebuild
parent0f3400581b3370a12b1581c6394b74327181f3e8 (diff)
gentoo auto-resync : 04:04:2023 - 23:23:40
Diffstat (limited to 'kde-plasma/plasma-integration/plasma-integration-5.27.4.ebuild')
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.27.4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.27.4.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.27.4.ebuild
new file mode 100644
index 000000000000..11eb3f2cd21c
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.27.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+VIRTUALX_REQUIRED="test"
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running kde environment
+RESTRICT="test"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.6.0
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+BDEPEND=">=dev-qt/qtwaylandscanner-${QTMIN}:5"