summaryrefslogtreecommitdiff
path: root/kde-plasma/oxygen/oxygen-5.22.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /kde-plasma/oxygen/oxygen-5.22.4.ebuild
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'kde-plasma/oxygen/oxygen-5.22.4.ebuild')
-rw-r--r--kde-plasma/oxygen/oxygen-5.22.4.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/kde-plasma/oxygen/oxygen-5.22.4.ebuild b/kde-plasma/oxygen/oxygen-5.22.4.ebuild
new file mode 100644
index 000000000000..8ba5dd7c0f31
--- /dev/null
+++ b/kde-plasma/oxygen/oxygen-5.22.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Oxygen visual style for the Plasma desktop"
+HOMEPAGE="https://invent.kde.org/plasma/oxygen"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="wayland"
+
+COMMON_DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/frameworkintegration-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-plasma/kdecoration-${PVCUT}:5
+ x11-libs/libxcb
+ wayland? ( >=kde-frameworks/kwayland-${KFMIN}:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kservice-${KFMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-plasma/plasma-desktop-5.16.80
+"
+PDEPEND="
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package wayland KF5Wayland)
+ )
+ ecm_src_configure
+}