summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-02 06:31:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-02 06:31:11 +0000
commitff733bfb4d0bd82175e03255004faef8721b53ea (patch)
treec1061dbb981bc9e61d4f31b6610569711c7b482f /kde-plasma/layer-shell-qt
parentc4d4d544a37efc45bd5482e62e1fcdbe7d5993d3 (diff)
gentoo auto-resync : 02:01:2025 - 06:31:11
Diffstat (limited to 'kde-plasma/layer-shell-qt')
-rw-r--r--kde-plasma/layer-shell-qt/Manifest2
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-6.2.5.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/Manifest b/kde-plasma/layer-shell-qt/Manifest
index 1d397a49fe90..8c770fc8abb0 100644
--- a/kde-plasma/layer-shell-qt/Manifest
+++ b/kde-plasma/layer-shell-qt/Manifest
@@ -1,3 +1,5 @@
DIST layer-shell-qt-6.2.4.tar.xz 35892 BLAKE2B f30ad3f6fea571a3ce5b78e9c0f66871a6891f35d4608386a1fe18f7f2eb9d46081f69773d0ca893c5e0bf003406fbfa3a6fd06e1285ceb004eacf579c6eba2a SHA512 d94353ebc9677ee4c11107892210034fc0ea75d6af157a351157df64d1ed4419196edd65c74a9f81e3ab7cdf5e75174faa1321a9aacd265769bb1b8c5a92d60d
+DIST layer-shell-qt-6.2.5.tar.xz 35972 BLAKE2B c9ad480a3af9d81a925a7bd5c02407141f3205251d2844438774e504aa6ad45f4da400de901816cf9083f9424d50038eb79814132e2d475216ffee50805d07bf SHA512 6eb158ceea1bb2ddb4a9f63a76d4d3082c2edde47a667485bfc01a27cfcefdd77ae093f254c7e5e7e9cbe8de59acbf4eee2f8f10f8a4091bee77006be7460dc9
EBUILD layer-shell-qt-6.2.4.ebuild 654 BLAKE2B a7504da2da139c73ee7cc72b4a565d287d4406584259646272f3f83f429f2ef45d384ae377b02f0e5cd02ec6ae689459c444cce9ab8ffd8d17184ae4b2b28a5f SHA512 deab9af41941e6dc4e1aebb03866220d397dc6950ad2834d8dd5610e8dafaf2e1c2608d66b9e300db8fa917e03c278404ad01bee2f8e6a324c8816f49ded206e
+EBUILD layer-shell-qt-6.2.5.ebuild 656 BLAKE2B 92c445b23ed155dcda39a7740ada59fb1d9bf84cc1fc8785ba0340ff1a071f29c4d1a6d9d43ed62d9571698f41fc945013e7a700197b44fe5dbff3071421a74f SHA512 416ac946055813b3b18b2066f89c7ea649ecbc9101cc7f17eb2d7e39dbb6990d34e5bdeafa7b1de843ea34e1aa4f9f2d262fb5837f5692fcb4a1cd1cf0a0d68b
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-6.2.5.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-6.2.5.ebuild
new file mode 100644
index 000000000000..94c30d8e5e68
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-6.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.6.0
+QTMIN=6.7.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"