summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-27 01:01:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-27 01:01:27 +0000
commit0b8b325c6d134a9f66de2ba751280e6480e609af (patch)
tree8b5d0bd7281bce9f308fec636204d20a29b4752a /kde-plasma/layer-shell-qt/layer-shell-qt-6.0.3.ebuild
parent82fd88ea93e273f4b02580552f808b6305d1e840 (diff)
gentoo auto-resync : 27:03:2024 - 01:01:27
Diffstat (limited to 'kde-plasma/layer-shell-qt/layer-shell-qt-6.0.3.ebuild')
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-6.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.3.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.3.ebuild
new file mode 100644
index 000000000000..9a1226aaba93
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"