summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt/layer-shell-qt-5.25.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:53:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:53:01 +0100
commit4b4d352fc9761396c68812d8eccc63b7b14d6558 (patch)
tree4f290d635d831599222130ba8ddbf1a726129426 /kde-plasma/layer-shell-qt/layer-shell-qt-5.25.4.ebuild
parenta2c1a301b2ea85c230b30ef69ff667f230a1bf88 (diff)
gentoo auto-resync : 03.08.2022 - 13:42:43
Diffstat (limited to 'kde-plasma/layer-shell-qt/layer-shell-qt-5.25.4.ebuild')
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-5.25.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-5.25.4.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-5.25.4.ebuild
new file mode 100644
index 000000000000..7aeba0ff0caf
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-5.25.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.95.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"