summaryrefslogtreecommitdiff
path: root/kde-plasma/ksysguard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /kde-plasma/ksysguard
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest2
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.12.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index eed68eba0987..40be94f4d9f9 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,3 +1,5 @@
DIST ksysguard-5.11.5.tar.xz 502228 BLAKE2B 49e82c26ea1c032e8e036e509c6a46c5da409f4092679a623bc26342f34ffa90d96306fb5638b1fe5a4edafe6f48af6ee12876286788b11145c00c1a32765edb SHA512 62af21b0d911abac5b66ccddeb0180c08199c0cfd8807d461fcfe444105ce7912efb5b8286e7f4955e97cb537edc32f046d646e82ecfc2d61ec39b2a53ed4d93
+DIST ksysguard-5.12.0.tar.xz 487248 BLAKE2B 46ca521c6149e1b2a5baffbd9248ac2f90c8b58b67b095936b5fb59399b1b4b9411fd0391e75cc1e93a57dfb1b1ec0def1a344375998caf30facad0ad1b5ae5d SHA512 d660b01d190860e42b4f21c420d6eb91da5f8cf35f658ecb13f19e86136070c14cba3c9ac13338c6586aee3ef5e8363c8e65597a7ecee2c5b88356ead292b9d9
EBUILD ksysguard-5.11.5.ebuild 1143 BLAKE2B bc2409ea028c763c822431abd58fe334cf5f3ab8430b43ec61cd53336e278f4a8bcb518e01d1de86607053fded35b8924bce024ababea2c904bd89159e57a6cc SHA512 3f50f88f16dde5a45742d8012d5a5601955b59c191aa82d0fa410425fa56e13faf3f8370a4f86d2eceda48790d9ffc12aeaf647a1689f5c1310ade072a8037c3
+EBUILD ksysguard-5.12.0.ebuild 1145 BLAKE2B 46054b5abb67d1b8f049c8bcc974ee3e2bf7c2029c151aa31688cab1b251e2913aa54bc6587361b2b7030ffed33aef8615af3a8d3641f1463458f374f29a635c SHA512 201d5337ec13c6b615401ea9b0ecf478224d454dc6dde1c9defddd9de9a980f9ab9f3b9061e1c3a84a5013cdb0964a7238b4a3b3caf83f741ce8c36fa9247209
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-plasma/ksysguard/ksysguard-5.12.0.ebuild b/kde-plasma/ksysguard/ksysguard-5.12.0.ebuild
new file mode 100644
index 000000000000..5e2260a85627
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.12.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}