summaryrefslogtreecommitdiff
path: root/kde-plasma/kinfocenter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /kde-plasma/kinfocenter
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest2
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.12.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 80664af3f8eb..91931a72c6f1 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,5 +1,7 @@
AUX kcm-about-distrorc 108 BLAKE2B 9324829040a699d8858a739b228b14035f8a33d4cc5e19af30545a6eb9780808b3350ca12c82a44a1868c32acddd76dcdb4e7b25e5792694b55fbb38ed23db8a SHA512 72f1dcaa04bfe435e64c8e584914eb56a15b63f7c6086f5e025f0c497b4fd5b9592d54aafd335f55d303790af274c9cbfa29c6c7ff87875da648ee16d7717467
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.11.5.tar.xz 1302960 BLAKE2B bd938c9c330c8f335825810e3fc8e8c97b1629d89bfeef0eb18bd4852f939f5ba0fb55640338b6d817c08d0b8f0099cdc303a19874811af52c35afd2a63a728c SHA512 d64cf466b4b883c9a57a0dddfe5a1d1cae0687655897803e5f14bcf73e90c1ea05d96458dbe131428c6d19a50d92b2614036136fdb897e422b1c1fc3d38f5303
+DIST kinfocenter-5.12.0.tar.xz 1268932 BLAKE2B d9b58bb8edcce96fe17fd4c3216ab5381456f654d139644bd873a2c2bfd91d5c10dc2bf948b665a20a3a6603d88dc9d4203d30dc3ac576c029b8f2a76060b6f4 SHA512 329d30bfe7ea509f814e85eb78bf21b0ee9b1b69910eeb3864708a586e12c28865756816bc6957b3f369e0386e2ab4f2f44a0f2e15b926970e09f5ed88b0709e
EBUILD kinfocenter-5.11.5.ebuild 2420 BLAKE2B da22bd0116013b3b79246f2a579b353381d9ec018efe97ddcf770a72ee76d57fdde18d52d4378851da577d9757f0fa507800d426a334c595f4ac0e4e8a174a4c SHA512 3f16d3bc5cf32511d53695315edebf42059971cb66e7d1c373d72ac71d883a56b3f887545344263e235a3a9477f620ba1e9fa4797023b6f6cf26002691b9a806
+EBUILD kinfocenter-5.12.0.ebuild 2422 BLAKE2B c64d5e3573160a015217f71835e009dd8b6e7962cad973f24f0ba958de182efe121c50d8e98ad76dc4afa4349ff0bfe1390203e4787635f73f00538f02c1ff52 SHA512 95c593960f555ec8c8254b8e974e07ab7f9aff34a739db3f86f282e7f805cc07d382480b08ac331506969b8388c7c427b65b6f6088f5ce4d073ac2353cdd50f0
MISC metadata.xml 390 BLAKE2B a47af94b17ade0ad2f4b4a44bac8ac1245c29a6551a059c95967ce2d5cd4420a975210bf0e4658c2152aaf5a894f934cac0d35aae015368bf1f8f8b1cbbbb069 SHA512 4ea690f0f5ac41b58d840949297d462e0fa7433bdece54d63b08a913d8a9001bf6d144e28d5e672712abf35e784c2b17faf31f0a879d6109417ce95ccdc0ef3b
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.12.0.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.12.0.ebuild
new file mode 100644
index 000000000000..ff2f95c95937
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.12.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-apps/kcontrol:4
+ !kde-misc/about-distro
+ !kde-plasma/kinfocenter:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gles2 OpenGLES)
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ einfo "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba" || ! has_version "net-fs/samba[server]"; then
+ einfo "Installing net-fs/samba[server(+)] will enable the Samba status information module."
+ fi
+}