summaryrefslogtreecommitdiff
path: root/kde-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-15 23:13:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-15 23:13:45 +0100
commite87ef1b6ce856ae8859bdfce8028fb992f3e3763 (patch)
treed51e0c41adf3586e9a393881cee3ec0a9ed48977 /kde-misc
parent0c80ffd3caee224555f8b394b6b2c05b2752f440 (diff)
gentoo auto-resync : 15:09:2022 - 23:13:44
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/Manifest.gzbin4783 -> 4948 bytes
-rw-r--r--kde-misc/bismuth/Manifest4
-rw-r--r--kde-misc/bismuth/bismuth-3.1.3.ebuild76
-rw-r--r--kde-misc/bismuth/metadata.xml14
4 files changed, 94 insertions, 0 deletions
diff --git a/kde-misc/Manifest.gz b/kde-misc/Manifest.gz
index 44804180b3d2..3f4c3717a26d 100644
--- a/kde-misc/Manifest.gz
+++ b/kde-misc/Manifest.gz
Binary files differ
diff --git a/kde-misc/bismuth/Manifest b/kde-misc/bismuth/Manifest
new file mode 100644
index 000000000000..e1631b06dc05
--- /dev/null
+++ b/kde-misc/bismuth/Manifest
@@ -0,0 +1,4 @@
+DIST bismuth-3.1.3-binary-release.tar.gz 187092 BLAKE2B 76672973b2102dffc3b5db9a00f49a291ac07e9b79ef282a9fe24a33ddd641cdebbaea20fd149f293625ff800000c4bf7aa28f40f62291c94ed3828540728b35 SHA512 6c42a4075dd97e3429075e69fd0604ef273afb4a22ec4dc14073ca2e02fd325ad8f6defc3943eec1e3a11a598c6ace41ac8825ba36b8d7d976b98d2d00cc1e73
+DIST bismuth-3.1.3.tar.gz 5473759 BLAKE2B fcacf2e6b491bbaccf52ec1227196b3a06535ae23371544762868b28b18ab5fe7cd0540376fd7ee34ac6d3fcd52d3ce61760c0252ff91acd7bc78896602e4c62 SHA512 fdfa1074d8c156c24cfe8b97ac99f1252c221f0ee2039d440645a08d6da405b7bf9b0479f1752cfadc9d05c21d3ad86923498cc190d69cc5f278c36888330a0c
+EBUILD bismuth-3.1.3.ebuild 1688 BLAKE2B 9b08d4a9c914b5a8cd09c215e7daa76a174a81081d24c3c110a6a8e619e9017a8b79e411d938d85fb9f29813f2c04a6486d75ff59c4107ed3e9b4918e4c93475 SHA512 d84e845a1ee035103b75377606984c94f129f925de51eda3148b024f8d55ca474e1adc653cb60ba2a893fad15858c9d6c41a8377245a3164a4123aea84acae70
+MISC metadata.xml 569 BLAKE2B d310b5e9f83bc770db6fa7a8c9a47438c3d084f33ab4e5029a83382629d8776a72638331f991ea41f9e33b062df0a7502b0a7ff4ac021fb2e75abe71929df283 SHA512 d0a8c04338ef2c5c75b9801bc2ad2e9da2bbd3b0a5192fbc0e1690732c160df482da6c5f783565bba062c756ecb48c434f7c3dd621b4f0f506c7c60f82101c0f
diff --git a/kde-misc/bismuth/bismuth-3.1.3.ebuild b/kde-misc/bismuth/bismuth-3.1.3.ebuild
new file mode 100644
index 000000000000..66e94643e779
--- /dev/null
+++ b/kde-misc/bismuth/bismuth-3.1.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Tiling window management script for Kwin"
+HOMEPAGE="https://github.com/Bismuth-Forge/bismuth"
+SRC_URI="
+ https://github.com/Bismuth-Forge/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Bismuth-Forge/bismuth/releases/download/v${PV}/binary-release.tar.gz -> ${P}-binary-release.tar.gz
+"
+
+LICENSE="CC-BY-4.0 LGPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+QTMIN=5.15.0
+KFMIN=5.78.0
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qttest-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-plasma/kwin-5.24.0:5
+"
+
+RDEPEND="${DEPEND}"
+
+RESTRICT=test # npm + js + hell + network
+
+src_prepare() {
+ # we are not building npm hell or tests
+ cmake_comment_add_subdirectory tests
+ cmake_run_in src cmake_comment_add_subdirectory kwinscript
+ cmake_src_prepare
+}
+
+src_configuire() {
+ # cmake calls git describe --tags --abbrev=0
+ # let's just echo expected output, e.g. v1.2.3
+ git() { echo "v${PV}" ; }
+ export -f git || die
+
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DUSE_NPM=OFF
+ -DUSE_TSC=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /usr/share/kwin/scripts
+ doins -r ../share/kwin/scripts/"${PN}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/kde-misc/bismuth/metadata.xml b/kde-misc/bismuth/metadata.xml
new file mode 100644
index 000000000000..d148c7d5dcff
--- /dev/null
+++ b/kde-misc/bismuth/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Bismuth-Forge/bismuth/issues</bugs-to>
+ <changelog>https://github.com/Bismuth-Forge/bismuth/blob/master/CHANGELOG.md</changelog>
+ <doc>https://github.com/Bismuth-Forge/bismuth/tree/master/docs</doc>
+ <remote-id type="github">Bismuth-Forge/bismuth</remote-id>
+ </upstream>
+</pkgmetadata>