summaryrefslogtreecommitdiff
path: root/kde-misc/skanlite/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /kde-misc/skanlite/files
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'kde-misc/skanlite/files')
-rw-r--r--kde-misc/skanlite/files/skanlite-2.1.0.1-cmake.patch (renamed from kde-misc/skanlite/files/skanlite-2.1.0-cmake.patch)49
1 files changed, 23 insertions, 26 deletions
diff --git a/kde-misc/skanlite/files/skanlite-2.1.0-cmake.patch b/kde-misc/skanlite/files/skanlite-2.1.0.1-cmake.patch
index fe5600c8c9a4..7b7daae11eac 100644
--- a/kde-misc/skanlite/files/skanlite-2.1.0-cmake.patch
+++ b/kde-misc/skanlite/files/skanlite-2.1.0.1-cmake.patch
@@ -1,17 +1,28 @@
-From ac188879ebf7cab5631213305f289bec4ab25613 Mon Sep 17 00:00:00 2001
+From 7c155671b5ea1a7ed1244510e79e094fc6f8ff4e Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 1 Apr 2018 13:36:48 +0200
-Subject: [PATCH 1/2] Cleanup CMakeLists.txt
+Date: Mon, 2 Apr 2018 21:27:52 +0200
+Subject: [PATCH] Cleanup CMakeLists.txt
+Summary:
Cleanup duplicate find Qt5 and move all below #Dependencies block.
Sort dependencies.
KF5Sane is not an actual framework, so separate it from KF5 modules.
+
+Make use of FeatureSummary
+
+Reviewers: sars
+
+Reviewed By: sars
+
+Subscribers: ltoscano
+
+Differential Revision: https://phabricator.kde.org/D11861
---
- CMakeLists.txt | 30 +++++++++++++-----------------
- 1 file changed, 13 insertions(+), 17 deletions(-)
+ CMakeLists.txt | 32 +++++++++++++++-----------------
+ 1 file changed, 15 insertions(+), 17 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d05fb37..6aacfb9 100644
+index 2c23351..6b326df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,44 +17,40 @@ include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
@@ -36,7 +47,7 @@ index d05fb37..6aacfb9 100644
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/src/version.h.cmake"
)
-+set(SKANLITE_VERSION_STRING "2.1.0")
++set(SKANLITE_VERSION_STRING "2.1.0.1")
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/version.h)
+
@@ -50,7 +61,7 @@ index d05fb37..6aacfb9 100644
-
include_directories(${PNG_INCLUDE_DIRS})
--set(SKANLITE_VERSION_STRING "2.1.0")
+-set(SKANLITE_VERSION_STRING "2.1.0.1")
-
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/version.h)
-
@@ -72,29 +83,15 @@ index d05fb37..6aacfb9 100644
add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
# Subdirectories
---
-2.16.3
-
-
-From 8bcc7e4fb701d2e95b8024df86830b9eeb6c97de Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 1 Apr 2018 13:50:34 +0200
-Subject: [PATCH 2/2] Make use of FeatureSummary
-
----
- CMakeLists.txt | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 6aacfb9..1736bff 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -58,3 +58,5 @@ add_subdirectory(src)
+@@ -62,6 +58,8 @@ add_subdirectory(src)
add_subdirectory(doc)
add_subdirectory(autotests)
add_subdirectory(tests)
+
+feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+
+ find_package(KF5I18n CONFIG REQUIRED)
+ ki18n_install(po)
--
2.16.3