summaryrefslogtreecommitdiff
path: root/kde-frameworks/syntax-highlighting/syntax-highlighting-5.102.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 05:54:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 05:54:04 +0000
commitbdc9b55c978e3939e16252e66e83950cbecbf77c (patch)
treeabab17826fc88c33d1b30eadaec18fcc6f2efb14 /kde-frameworks/syntax-highlighting/syntax-highlighting-5.102.0.ebuild
parent3bd85407abc9ed4434c2d3741f84fdb512638b1c (diff)
gentoo auto-resync : 15:01:2023 - 05:54:04
Diffstat (limited to 'kde-frameworks/syntax-highlighting/syntax-highlighting-5.102.0.ebuild')
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.102.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.102.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.102.0.ebuild
new file mode 100644
index 000000000000..13b13eb12b65
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.102.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ >=dev-qt/linguist-tools-${QTMIN}:5
+"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}