summaryrefslogtreecommitdiff
path: root/kde-frameworks/purpose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /kde-frameworks/purpose
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest2
-rw-r--r--kde-frameworks/purpose/purpose-5.61.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 98cfac3721fa..05c8eff449ab 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,3 +1,5 @@
DIST purpose-5.60.0.tar.xz 147472 BLAKE2B c29506d7d1cb4adb09705b40e10ff4459c8c9dca68667f9c64aa4268fa202fcc949703d6855148e9c8934135b25990de84f68e0942c5e7050322a3623e05dc55 SHA512 0d26fb1b8d0d50843da036a1f6f789ae2457afb9ab449d45be35fca79712b6d8a7974faa89bc5f6605dd8b738bb1011a6cd8d294dfdf118339f784083808d3af
+DIST purpose-5.61.0.tar.xz 149240 BLAKE2B e6bdb2246e913efe1f367bb85f2b8fc4de17a8c6e8dcd2d0683d8654bf55703b9be879e38ee2c60f140f3ea88556fe1b2389ab44a693c236d005b4727fc852b0 SHA512 75ea323538df7114fded44a95d5772ccaecf375e2f6f888b30619ec5f1427ba437af2f10aef25d22ebb276086ba359d45442e02ace47d5448fc0ce533b09daa9
EBUILD purpose-5.60.0.ebuild 1034 BLAKE2B 4eabde15b9bf52cb6216576ec37fd3099057fceeb05e6b097f0e3cde5769ba5de88c861e7720c773b7788d93f787451e40b6d61a531e3452391b8806363f01e8 SHA512 1ff99641664ee97b56dedf36efc7dfd6c3101b7eedda35af98469602062cd92c815c4570128c05a9e6acef3b6454ffb77be5121884a3d46280dc6abc43778114
+EBUILD purpose-5.61.0.ebuild 1037 BLAKE2B d20672c7a89d872559eb0e9546c48abcb6793db5617eb3cb29d844532817cd620f36fb394cf23ab228a480b62c1c678bb536f22899e56fff67689b91f0ae7553 SHA512 8ce5911ceca2f230b3806070cba6be27a2d9c2159b4ad0310330f84b3605d7ed73247413ab80d416189d8790609d978716553c49de71a1d62dff2a738bbf2478
MISC metadata.xml 345 BLAKE2B 0e6eede785554aad84ff8d6703b9ab698439d7c383b26f789ea3d6234014b4e4de329159a6264eb37375581106ffa1588d508d2616aac298af08644d1ad02183 SHA512 cee07f4f8ede80430680300afba2bbbba3f38559fec0b3d0dac805beaadf9605f94d4cc23a0f213bc56f6bd48aa5f4f39f010b87453351211ef1c6d53393f26d
diff --git a/kde-frameworks/purpose/purpose-5.61.0.ebuild b/kde-frameworks/purpose/purpose-5.61.0.ebuild
new file mode 100644
index 000000000000..9fb40862382b
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.61.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+kaccounts"
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kirigami)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ kaccounts? (
+ $(add_kdeapps_dep kaccounts-integration)
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kaccounts KAccounts)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ fi
+}