summaryrefslogtreecommitdiff
path: root/kde-frameworks/kwayland/kwayland-5.70.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /kde-frameworks/kwayland/kwayland-5.70.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'kde-frameworks/kwayland/kwayland-5.70.0.ebuild')
-rw-r--r--kde-frameworks/kwayland/kwayland-5.70.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/kwayland/kwayland-5.70.0.ebuild b/kde-frameworks/kwayland/kwayland-5.70.0.ebuild
new file mode 100644
index 000000000000..732ad8861ee2
--- /dev/null
+++ b/kde-frameworks/kwayland/kwayland-5.70.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://cgit.kde.org/kwayland.git"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ media-libs/mesa[egl]
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/wayland-protocols-1.15
+"
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"