summaryrefslogtreecommitdiff
path: root/kde-frameworks/kwayland/kwayland-5.69.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /kde-frameworks/kwayland/kwayland-5.69.0-r1.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'kde-frameworks/kwayland/kwayland-5.69.0-r1.ebuild')
-rw-r--r--kde-frameworks/kwayland/kwayland-5.69.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/kwayland/kwayland-5.69.0-r1.ebuild b/kde-frameworks/kwayland/kwayland-5.69.0-r1.ebuild
new file mode 100644
index 000000000000..62e01942123b
--- /dev/null
+++ b/kde-frameworks/kwayland/kwayland-5.69.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://cgit.kde.org/kwayland.git"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[egl]
+ >=dev-libs/wayland-1.15.0
+ media-libs/mesa[egl]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/wayland-protocols-1.15
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtwayland-${QTMIN}:5
+"
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"