summaryrefslogtreecommitdiff
path: root/kde-frameworks/krunner/krunner-5.70.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /kde-frameworks/krunner/krunner-5.70.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'kde-frameworks/krunner/krunner-5.70.0.ebuild')
-rw-r--r--kde-frameworks/krunner/krunner-5.70.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-frameworks/krunner/krunner-5.70.0.ebuild b/kde-frameworks/krunner/krunner-5.70.0.ebuild
new file mode 100644
index 000000000000..a92875e48e26
--- /dev/null
+++ b/kde-frameworks/krunner/krunner-5.70.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing different actions given a string query"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/plasma-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ =kde-frameworks/threadweaver-${PVCUT}*:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ # requires virtual dbus #630672
+ local myctestargs=(
+ -E "(dbusrunnertest)"
+ )
+ ecm_src_test
+}