summaryrefslogtreecommitdiff
path: root/kde-frameworks/kquickcharts/kquickcharts-5.85.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /kde-frameworks/kquickcharts/kquickcharts-5.85.0.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'kde-frameworks/kquickcharts/kquickcharts-5.85.0.ebuild')
-rw-r--r--kde-frameworks/kquickcharts/kquickcharts-5.85.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/kquickcharts/kquickcharts-5.85.0.ebuild b/kde-frameworks/kquickcharts/kquickcharts-5.85.0.ebuild
new file mode 100644
index 000000000000..6d75dca5d2aa
--- /dev/null
+++ b/kde-frameworks/kquickcharts/kquickcharts-5.85.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_EXAMPLES="true"
+ECM_QTHELP="false"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="QtQuick plugin providing high-performance charts"
+HOMEPAGE="https://invent.kde.org/frameworks/kquickcharts"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ examples? (
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ )
+
+ ecm_src_configure
+}