summaryrefslogtreecommitdiff
path: root/kde-frameworks/kparts/kparts-5.111.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-19 21:52:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-19 21:52:41 +0100
commit67efaff61522aeb024152ab6cddf7c40ffacb530 (patch)
tree294409103a6f391c6c9d317b2dde60cbf1f035e7 /kde-frameworks/kparts/kparts-5.111.0.ebuild
parentf827ced0163cc11d6d35e2d4e2c8a7ab3fd6482a (diff)
gentoo auto-resync : 19:10:2023 - 21:52:41
Diffstat (limited to 'kde-frameworks/kparts/kparts-5.111.0.ebuild')
-rw-r--r--kde-frameworks/kparts/kparts-5.111.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/kparts/kparts-5.111.0.ebuild b/kde-frameworks/kparts/kparts-5.111.0.ebuild
new file mode 100644
index 000000000000..efbad46843a8
--- /dev/null
+++ b/kde-frameworks/kparts/kparts-5.111.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework providing elaborate user-interface components"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ >=kde-frameworks/ktextwidgets-${PVCUT}:5
+"